aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-08-25 16:40:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:06 +0200
commitc7a28011177cb14a695ed2fd2d4b6ed2b6b404da (patch)
treeb90efb98c59cfb083b47d8b3a16aeaa0372feff8
parent5ecae0f0c1b161bff3fe7479178e5ce3517b226d (diff)
downloadmeta-openembedded-contrib-c7a28011177cb14a695ed2fd2d4b6ed2b6b404da.tar.gz
python-html5lib: add Python3 support
Extend the recipe for Python3 support. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-html5lib.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb16
-rw-r--r--meta-python/recipes-devtools/python/python3-html5lib_0.999999999.bb2
3 files changed, 18 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-html5lib.inc b/meta-python/recipes-devtools/python/python-html5lib.inc
new file mode 100644
index 0000000000..9c59e0d18c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-html5lib.inc
@@ -0,0 +1,14 @@
+SUMMARY = "HTML parser based on the WHATWG HTML specifcation"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
+
+SRC_URI[md5sum] = "8578e4e3a341436cb9743a9e4a299239"
+SRC_URI[sha256sum] = "ee747c0ffd3028d2722061936b5c65ee4fe13c8e4613519b4447123fc4546298"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-webencodings \
+ ${PYTHON_PN}-xml \
+ "
diff --git a/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb b/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb
index d0f7b56ee4..f5941a2a11 100644
--- a/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb
+++ b/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb
@@ -1,14 +1,2 @@
-SUMMARY = "HTML parser based on the WHATWG HTML specifcation"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
-
-SRC_URI[md5sum] = "8578e4e3a341436cb9743a9e4a299239"
-SRC_URI[sha256sum] = "ee747c0ffd3028d2722061936b5c65ee4fe13c8e4613519b4447123fc4546298"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-webencodings \
- ${PYTHON_PN}-xml \
- "
+inherit setuptools
+require python-html5lib.inc
diff --git a/meta-python/recipes-devtools/python/python3-html5lib_0.999999999.bb b/meta-python/recipes-devtools/python/python3-html5lib_0.999999999.bb
new file mode 100644
index 0000000000..6bd8b49f55
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-html5lib_0.999999999.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-html5lib.inc