aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordouglas.royds <douglas.royds@taitradio.com>2018-11-13 18:08:35 +1300
committerKhem Raj <raj.khem@gmail.com>2018-11-13 08:32:18 -0800
commit13335e4e8e4b91ac5cc52a6754f0478c07fc7005 (patch)
tree1e36bb0be58619138d65a639543695844d5b0e42
parent9535ee3321f933b0f6c9bc810a5047c496b56b32 (diff)
downloadmeta-openembedded-contrib-13335e4e8e4b91ac5cc52a6754f0478c07fc7005.tar.gz
ntp: Reproducible build: Use fixed path to posix shell
At configure time, the ntp build goes looking on the build machine for a posix shell, using `which` to find it. Under OE, it settles on hosttools/bash, resulting in this build host path being written into several binaries. This did not affect the Debian reproducibility project, presumably because it consistently found bash at /bin/bash. Don't go looking, just use a fixed path to /bin/sh instead. Upstream-Status: Submitted http://bugs.ntp.org/show_bug.cgi?id=3551 Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/ntp/ntp/reproducibility-fixed-path-to-posix-shell.patch15
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb1
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp/reproducibility-fixed-path-to-posix-shell.patch b/meta-networking/recipes-support/ntp/ntp/reproducibility-fixed-path-to-posix-shell.patch
new file mode 100644
index 0000000000..571db75f7c
--- /dev/null
+++ b/meta-networking/recipes-support/ntp/ntp/reproducibility-fixed-path-to-posix-shell.patch
@@ -0,0 +1,15 @@
+--- ntp-4.2.8p12.original/sntp/libopts/m4/libopts.m4 2018-11-12 17:54:57.747220846 +1300
++++ ntp-4.2.8p12/sntp/libopts/m4/libopts.m4 2018-11-12 18:00:50.626211641 +1300
+@@ -114,12 +114,6 @@
+ AC_PROG_SED
+ [while :
+ do
+- POSIX_SHELL=`which bash`
+- test -x "$POSIX_SHELL" && break
+- POSIX_SHELL=`which dash`
+- test -x "$POSIX_SHELL" && break
+- POSIX_SHELL=/usr/xpg4/bin/sh
+- test -x "$POSIX_SHELL" && break
+ POSIX_SHELL=`/bin/sh -c '
+ exec 2>/dev/null
+ if ! true ; then exit 1 ; fi
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb
index 536679f4d5..53e41297aa 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb
@@ -12,6 +12,7 @@ DEPENDS = "libevent"
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \
file://ntp-4.2.4_p6-nano.patch \
+ file://reproducibility-fixed-path-to-posix-shell.patch \
file://reproducibility-respect-source-date-epoch.patch \
file://ntpd \
file://ntp.conf \