aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-02 11:24:24 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:56 +0100
commit32b0092f6f6bb6687633e24ab44cf0f2ab73c810 (patch)
treedca9af898454cdfe130ef1633dcfde7099a3d447
parent8173c31a017bf40c44e9de8ff4288b100b48ab74 (diff)
downloadmeta-openembedded-contrib-32b0092f6f6bb6687633e24ab44cf0f2ab73c810.tar.gz
python-simplejson: relocate to meta-python and add a python3 version
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-simplejson.inc (renamed from meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb)21
-rw-r--r--meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb7
3 files changed, 15 insertions, 15 deletions
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson.inc
index 75ec2dc2d3..2eed199655 100644
--- a/meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb
+++ b/meta-python/recipes-devtools/python/python-simplejson.inc
@@ -1,26 +1,17 @@
SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
-SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
-SRCNAME = "simplejson"
-
-SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15"
SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
+inherit pypi
-RDEPENDS_${PN} = "\
- python-core \
- python-re \
- python-io \
- python-netserver \
- python-numbers \
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-re \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
"
-
-
diff --git a/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb
new file mode 100644
index 0000000000..e33edfebaa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-simplejson.inc
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb
new file mode 100644
index 0000000000..d44bc1526d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb
@@ -0,0 +1,7 @@
+inherit setuptools3
+require python-simplejson.inc
+
+# Requires _pydecimal which is in misc
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+"