aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-24 11:44:57 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:14:15 +0200
commitdb1ceb94283fcc15d4c0ae812f85b9212cec1ba9 (patch)
tree2aa1a90396fc23da3349b4b1f6b2b0e9258b91aa
parentdd5b81adff4b2e6d189b67684446aaac8b504d8b (diff)
downloadmeta-openembedded-contrib-db1ceb94283fcc15d4c0ae812f85b9212cec1ba9.tar.gz
efibootmgr: Fix build with gcc 7
backport patch to remove double const in decls Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch49
-rw-r--r--meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch b/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch
new file mode 100644
index 0000000000..b6211c28a1
--- /dev/null
+++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch
@@ -0,0 +1,49 @@
+From a9f8d414972b0b7c963d7efe38b5cfdcb6413c46 Mon Sep 17 00:00:00 2001
+From: Peter Jones <pjones@redhat.com>
+Date: Mon, 6 Feb 2017 16:34:54 -0500
+Subject: [PATCH] Remove extra const keywords gcc 7 gripes about.
+
+Signed-off-by: Peter Jones <pjones@redhat.com>
+---
+ src/efibootdump.c | 2 +-
+ src/efibootmgr.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/efibootdump.c b/src/efibootdump.c
+index 3e448c2..5a9b681 100644
+--- a/src/efibootdump.c
++++ b/src/efibootdump.c
+@@ -36,7 +36,7 @@ print_boot_entry(efi_load_option *loadopt, size_t data_size)
+ uint8_t *optional_data = NULL;
+ size_t optional_data_len = 0;
+ uint16_t pathlen;
+- const unsigned char const *desc;
++ const unsigned char *desc;
+ char *raw;
+ size_t raw_len;
+
+diff --git a/src/efibootmgr.c b/src/efibootmgr.c
+index baefa68..683623b 100644
+--- a/src/efibootmgr.c
++++ b/src/efibootmgr.c
+@@ -214,7 +214,7 @@ warn_duplicate_name(list_t *boot_list)
+ list_t *pos;
+ var_entry_t *boot;
+ efi_load_option *load_option;
+- const unsigned char const *desc;
++ const unsigned char *desc;
+
+ list_for_each(pos, boot_list) {
+ boot = list_entry(pos, var_entry_t, list);
+@@ -821,7 +821,7 @@ show_boot_vars()
+ {
+ list_t *pos;
+ var_entry_t *boot;
+- const unsigned char const *description;
++ const unsigned char *description;
+ efi_load_option *load_option;
+ efidp dp = NULL;
+ unsigned char *optional_data = NULL;
+--
+2.12.2
+
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb
index b25cfcabd3..193150bb9f 100644
--- a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb
+++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb
@@ -12,6 +12,7 @@ COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
SRCREV = "75d25807ba81cb724964c989012611272c8f1f5d"
SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
+ file://0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch \
"
S = "${WORKDIR}/git"