aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEren Türkay <eren@hambedded.org>2013-08-23 14:18:03 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-03 19:12:40 +0200
commit06673b1e9d8ff4f5f11f01c763e4a6f841836cf4 (patch)
tree1545d30e455b9696325a13d4bb9a1eed32a10855
parent824047d132133331e4727a1ff2cffc598bf9b286 (diff)
downloadmeta-openembedded-contrib-06673b1e9d8ff4f5f11f01c763e4a6f841836cf4.tar.gz
mpg123: add PACKAGECONFIG for pulseaudio and alsa
The default DISTRO_FEATURES include alsa and pulseaudio at the same time. Hence, both of the options are enabled in mpg123 configuration without adding related dependencies, which causes build error. Make the options mutually exclusive through PACKAGECONFIG. If both alsa and pulseaudio are specified, pulseaudio takes precedence. Signed-off-by: Eren Türkay <eren@hambedded.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb b/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb
index 595235cd2f..0075427331 100644
--- a/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb
+++ b/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb
@@ -6,6 +6,14 @@ HOMEPAGE = "http://mpg123.de/"
BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
SECTION = "multimedia"
+# The options should be mutually exclusive for configuration script.
+# If both alsa and pulseaudio are specified (as in the default distro features)
+# pulseaudio takes precedence.
+PACKAGECONFIG_ALSA = "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
+PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
+PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
+
LICENSE = "LGPLv2.1"
LICENSE_FLAGS = "commercial"
LIC_FILES_CHKSUM = "file://COPYING;md5=a7aa23a2b646eca38ad4eeb7a853761c"
@@ -23,7 +31,5 @@ EXTRA_OECONF = " \
--enable-shared \
${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', '--with-default-audio=alsa', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', '--with-default-audio=pulse', '', d)} \
"