aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-22 15:22:53 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-24 14:50:27 +0100
commit20506c8cb4369a219ecfa892065917b930b910a5 (patch)
tree5ca0f38d6c1af468b78803c944a192946762b542
parent80ef3c0aa0f92e93d1581e47ccb77a04022d04cf (diff)
downloadmeta-openembedded-contrib-20506c8cb4369a219ecfa892065917b930b910a5.tar.gz
apache2: avoid injecting host include path
includedir (by way of EXTRA_INCLUDES) gets into the CFLAGS of modphp via apxs; thus it should not point to a location on the host. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
index 5857be7ded..af7840d1a5 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://httpd.apache.org/"
DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util"
SECTION = "net"
LICENSE = "Apache-2.0"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \
file://server-makefile.patch \
@@ -93,6 +93,7 @@ apache_sysroot_preprocess () {
sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
+ sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
}
#