aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Bigot <pab@pabigot.com>2014-08-28 07:06:19 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-01 11:37:12 +0200
commit1eff1134a041e1abb32b2f134ae23c4316a0db60 (patch)
treedc7acac6044cd24fcee947afa891b398227086b7
parent3bd654324cdf2485249b1dcb49d2da8a7ded41d1 (diff)
downloadmeta-openembedded-contrib-1eff1134a041e1abb32b2f134ae23c4316a0db60.tar.gz
pps-tools: add recipe
This provides some utilities and a user-space header necessary to use the Linux KPPS (RFC 2783) capabilities of gpsd and ntp. Signed-off-by: Peter A. Bigot <pab@pabigot.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/pps-tools/pps-tools_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pps-tools/pps-tools_git.bb b/meta-oe/recipes-support/pps-tools/pps-tools_git.bb
new file mode 100644
index 0000000000..73c46eecde
--- /dev/null
+++ b/meta-oe/recipes-support/pps-tools/pps-tools_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "User-space tools for LinuxPPS"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+PV = "0.0.0+git${SRCPV}"
+SRCREV = "0deb9c7e135e9380a6d09e9d2e938a146bb698c8"
+SRC_URI = "git://github.com/ago/pps-tools.git"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir} ${D}${includedir} \
+ ${D}${includedir}/sys
+ oe_runmake 'DESTDIR=${D}' install
+}