aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-08-25 15:26:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-27 12:49:20 +0200
commit46698617eb3ee7a5a2c638759654b6076a7bc058 (patch)
tree66e40e6653c7cb78ca83d9ec0e6c7b0367a41546
parent49cb17b4978bf586311f5b8ab4b1b3810098c297 (diff)
downloadmeta-openembedded-contrib-46698617eb3ee7a5a2c638759654b6076a7bc058.tar.gz
e-wm: add git recipe with latest revision
* E19 is still in alpha stage, but I was told that many things work there better than old(ish) E18 * last announcement: https://phab.enlightenment.org/phame/live/3/post/e19_alpha2_now_with_50_more_explosions/ * but be aware that illume2 modules are gone and config mobile doesn't work without them * there is new tiling config Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/recipes-efl/e17/e-wm.inc5
-rw-r--r--meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch29
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_0.18.8.bb6
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_git.bb14
4 files changed, 48 insertions, 6 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm.inc b/meta-efl/recipes-efl/e17/e-wm.inc
index 122a60e8b4..0ff26ef9cd 100644
--- a/meta-efl/recipes-efl/e17/e-wm.inc
+++ b/meta-efl/recipes-efl/e17/e-wm.inc
@@ -10,6 +10,8 @@ S = "${WORKDIR}/${SRCNAME}"
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
+PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
+
EXTRA_OECONF = "\
--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
@@ -21,6 +23,7 @@ EXTRA_OECONF = "\
do_configure_prepend() {
autopoint || true
+ sed '/^ *EFL_PKG_CHECK_VAR/ s/systemduserunitdir/systemdsystemunitdir/g' -i ${S}/configure.ac
}
do_install_append() {
@@ -70,6 +73,7 @@ PACKAGES =+ "\
${PN}-config-netbook \
${PN}-config-scaleable \
${PN}-config-standard \
+ ${PN}-config-tiling \
${PN}-theme-default \
${PN}-background-dark-gradient \
${PN}-background-light-gradient \
@@ -126,6 +130,7 @@ FILES_${PN}-config-minimalist = "${datadir}/enlightenment/data/config/minimalist
FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook"
FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable"
FILES_${PN}-config-standard = "${datadir}/enlightenment/data/config/standard"
+FILES_${PN}-config-tiling = "${datadir}/enlightenment/data/config/tiling"
FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
FILES_${PN}-background-dark-gradient = "${datadir}/enlightenment/data/backgrounds/Dark_Gradient.edj"
diff --git a/meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch b/meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch
new file mode 100644
index 0000000000..14899d5147
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch
@@ -0,0 +1,29 @@
+From 8526270c418a5dc3d737a8eaff315209433f69d2 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Mon, 25 Aug 2014 16:06:03 +0200
+Subject: [PATCH] configure.ac: add foreign
+
+* fixes:
+ | configure.ac:312: error: required file './ABOUT-NLS' not found
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 62c0f6d..49b290b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,7 +34,7 @@ AH_BOTTOM([
+ #endif /* EFL_CONFIG_H__ */
+ ])
+
+-AM_INIT_AUTOMAKE([1.11 dist-bzip2 -Wno-portability])
++AM_INIT_AUTOMAKE([1.11 dist-bzip2 -Wno-portability foreign])
+ AM_SILENT_RULES([yes])
+
+ AC_USE_SYSTEM_EXTENSIONS
+--
+2.0.4
+
diff --git a/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb b/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb
index 0d65ca0bf5..6b4c9fc542 100644
--- a/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb
@@ -13,9 +13,3 @@ SRC_URI = "\
SRC_URI[md5sum] = "79c9f524e1d0510061c62c4b038a8ece"
SRC_URI[sha256sum] = "14c9bde4334d2f8b0776c6113d02b923ab159eea1cbf7013489e4f3bf37a51bb"
-
-do_configure_prepend() {
- sed '/^ *EFL_PKG_CHECK_VAR/ s/systemduserunitdir/systemdsystemunitdir/g' -i ${S}/configure.ac
-}
-
-PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
diff --git a/meta-efl/recipes-efl/e17/e-wm_git.bb b/meta-efl/recipes-efl/e17/e-wm_git.bb
new file mode 100644
index 0000000000..4bf1b96936
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/e-wm_git.bb
@@ -0,0 +1,14 @@
+require ${BPN}.inc
+
+PV = "0.18.999+0.19-alpha2+git${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = " \
+ git://git.enlightenment.org/core/enlightenment.git \
+ file://0001-configure.ac-add-foreign.patch \
+ file://enlightenment_start.oe \
+ file://applications.menu \
+"
+S = "${WORKDIR}/git"
+
+SRCREV = "525b963133d7168226b8e07ba26730212a8b7e82"