aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-12-06 10:06:56 -0800
committerKhem Raj <raj.khem@gmail.com>2021-12-06 10:15:36 -0800
commit67df2ce4c96a689276318a27a8f7b85553aa799c (patch)
tree3de9a77de52a21d419b57dbfe1e6de90f0a3362f
parentc2a611d45a763ae29ae0262895c01b45fd85553b (diff)
downloadmeta-openembedded-contrib-67df2ce4c96a689276318a27a8f7b85553aa799c.tar.gz
libunix-statgrab: Use compiler driver for linking as well
the build system tries to deduce the compiler and its friends and fails because OE passes LDFLAGS assuming that linker will be invoked via compiler driver ( gcc or clang ) therefore prefixes linker options with -Wl, but libunix-statgrab build system enquires LD variable for linker and uses LDFLAGS with it, which causes linker to fail since ld does not recognise -Wl, etc. Therefore using CCLD for linker is right choice here Fixes Checking for cc... i686-yoe-linux-ld: unrecognized option '-Wl,-O1' i686-yoe-linux-ld: use the --help option for usage information Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb b/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb
index 7af7f92fb9..c2b6d4abf8 100644
--- a/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb
+++ b/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb
@@ -33,6 +33,8 @@ SRC_URI[sha256sum] = "16a29f7acaeec081bf0e7303ba5ee24fda1d21a1104669b837745f3ea6
S = "${WORKDIR}/Unix-Statgrab-${PV}"
+export LD = "${CCLD}"
+
inherit cpan pkgconfig ptest-perl
BBCLASSEXTEND = "native"