aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-07-07 16:01:12 +0800
committerKhem Raj <raj.khem@gmail.com>2022-07-07 08:24:26 -0700
commited42504a985d973f73e51d452427c8e267425997 (patch)
treecdb569ab976047a72835515112526dad9c37c5e7
parent79c71335803d8859eb419c208aa3f66722d54fc4 (diff)
downloadmeta-openembedded-contrib-ed42504a985d973f73e51d452427c8e267425997.tar.gz
python3-grpcio: upgrade 1.45.0 -> 1.47.0
0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch refreshed for new version. Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch25
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb (renamed from meta-python/recipes-devtools/python/python3-grpcio_1.45.0.bb)2
2 files changed, 17 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index febe6c4c87..f416ca2728 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -28,42 +28,49 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
src/python/grpcio/commands.py | 5 ++++-
2 files changed, 10 insertions(+), 4 deletions(-)
+diff --git a/setup.py b/setup.py
+index ec27fe4..b2d2d1a 100644
--- a/setup.py
+++ b/setup.py
-@@ -199,8 +199,11 @@ def check_linker_need_libatomic():
+@@ -206,8 +206,11 @@ def check_linker_need_libatomic():
"""Test if linker on system needs libatomic."""
code_test = (b'#include <atomic>\n' +
b'int main() { return std::atomic<int64_t>{}; }')
-- cxx = os.environ.get('CXX', 'c++')
-- cpp_test = subprocess.Popen([cxx, '-x', 'c++', '-std=c++11', '-'],
+- cxx = shlex.split(os.environ.get('CXX', 'c++'))
+- cpp_test = subprocess.Popen(cxx + ['-x', 'c++', '-std=c++14', '-'],
+ cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++'
+ if not cxx_args:
+ cxx_args = "-g"
+
-+ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++11', '-'],
++ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++14', '-'],
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)
-@@ -210,7 +213,7 @@ def check_linker_need_libatomic():
+@@ -217,7 +220,7 @@ def check_linker_need_libatomic():
# Double-check to see if -latomic actually can solve the problem.
# https://github.com/grpc/grpc/issues/22491
cpp_test = subprocess.Popen(
-- [cxx, '-x', 'c++', '-std=c++11', '-', '-latomic'],
-+ [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-', '-latomic'],
+- [cxx, '-x', 'c++', '-std=c++14', '-', '-latomic'],
++ [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'],
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)
+diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py
+index d93b6c7..a8c4a51 100644
--- a/src/python/grpcio/commands.py
+++ b/src/python/grpcio/commands.py
@@ -228,7 +228,10 @@ class BuildExt(build_ext.build_ext):
"""
try:
# TODO(lidiz) Remove the generated a.out for success tests.
-- cc_test = subprocess.Popen(['cc', '-x', 'c', '-std=c++11', '-'],
+- cc_test = subprocess.Popen(['cc', '-x', 'c', '-std=c++14', '-'],
+ cc_test, cc_args = os.environ.get('CC').split(' ', 1) or 'gcc'
+ if not cc_args:
+ cc_args = "-g"
-+ cc_test = subprocess.Popen([cc_test, cc_args, '-x', 'c', '-std=c++11', '-'],
++ cc_test = subprocess.Popen([cc_test, cc_args, '-x', 'c', '-std=c++14', '-'],
stdin=subprocess.PIPE,
stdout=subprocess.PIPE,
stderr=subprocess.PIPE)
+--
+2.25.1
+
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.45.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb
index ca55a7f091..24c6e53447 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.45.0.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb
@@ -13,7 +13,7 @@ SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \
file://0001-absl-always-use-asm-sgidefs.h.patch \
file://abseil-ppc-fixes.patch;patchdir=third_party/abseil-cpp \
"
-SRC_URI[sha256sum] = "ff2c8b965b0fc25cf281961aa46619c10900543effe3f806ef818231c40aaff3"
+SRC_URI[sha256sum] = "5dbba95fab9b35957b4977b8904fc1fa56b302f9051eff4d7716ebb0c087f801"
RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \
${PYTHON_PN}-setuptools \