aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-03-08 10:55:11 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-08 08:06:33 -0800
commit1abb2c6c43117e405806470119408bbde516fd4b (patch)
treef6167841ad6b0ada3ae174a796620a19fc1440b9
parent81693af8b430c0065f0c21e387278b946b328ca6 (diff)
downloadmeta-openembedded-contrib-1abb2c6c43117e405806470119408bbde516fd4b.tar.gz
Revert "python3-ipy: drop recipe"
This reverts commit df077258b61f20ec8fdf3978fa4a912d3a14eaf5. Add python3-ipy back and inherit setuptools3-legacy. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy_1.01.bb32
3 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 670361598e..9626231bba 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -189,6 +189,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-intelhex \
python3-intervals \
python3-ipaddress \
+ python3-ipy \
python3-ipython \
python3-ipython-genutils \
python3-iso3166 \
@@ -498,6 +499,7 @@ RDEPENDS:packagegroup-meta-python3-ptest = "\
python3-html2text-ptest \
python3-inflection-ptest \
python3-intervals-ptest \
+ python3-ipy-ptest \
python3-iso3166-ptest \
python3-jdcal-ptest \
python3-jinja2-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-ipy/run-ptest b/meta-python/recipes-devtools/python/python3-ipy/run-ptest
new file mode 100644
index 0000000000..b63c4de0d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipy/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-ipy_1.01.bb b/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
new file mode 100644
index 0000000000..8e7b5b987e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
@@ -0,0 +1,32 @@
+SUMMARY = "IPy - class and tools for handling of IPv4 and IPv6 addresses and networks"
+DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
+in a fashion similar to perl's Net::IP and friends. The IP class allows \
+a comfortable parsing and handling for most notations in use for IPv4 \
+and IPv6 Addresses and Networks."
+SECTION = "devel/python"
+HOMEPAGE = "https://github.com/autocracy/python-ipy"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6"
+
+SRC_URI[md5sum] = "d6cf83e7f418ebbd23324ba1c658b907"
+SRC_URI[sha256sum] = "edeca741dea2d54aca568fa23740288c3fe86c0f3ea700344571e9ef14a7cc1a"
+
+inherit pypi setuptools3_legacy ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test/
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test
+}
+
+PYPI_PACKAGE = "IPy"
+
+BBCLASSEXTEND = "native"