aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-05-07 07:13:20 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-12 11:53:30 -0400
commit273d79740b69deb63672705848613de64acfeaf2 (patch)
tree15bc41415cf061ad27c6932308d89c32fb6dc72c
parent8b5662be65fccd26d241cdc2b561032e13c1e63f (diff)
downloadmeta-openembedded-contrib-273d79740b69deb63672705848613de64acfeaf2.tar.gz
wireshark: Fix new QA Error
NOTE: Resolving any missing task queue dependencies ERROR: Nothing PROVIDES 'libepoxy' (but /oss/maint/mylayers/openembedded-core/meta/recipes-gnome/gtk+/gtk+3_3.18.8.bb DEPENDS on or otherwise requires it) ERROR: libepoxy was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES) add DISTRO_FEATURES check for opengl to enable gtk3 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb b/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
index b264e67a23..76cb30a915 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
@@ -18,11 +18,12 @@ inherit autotools pkgconfig
ARM_INSTRUCTION_SET = "arm"
# Works with either gtk+ or gtk3.
-WHICH_GTK = "gtk3"
+WHICH_GTK = "gtk+"
PACKAGECONFIG ?= "libpcap gnutls libnl libcap"
-PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
+PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
+#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"