aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-11 14:21:18 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-12 19:39:11 +0100
commit48a62d1a72190420205c4d7e015c3df092ae66c8 (patch)
tree22fcd9fceed29b3a218b11db180d113f2708fce0
parentf36e2e2ea4edcd4a0e65ed1c213bce388231214c (diff)
downloadmeta-openembedded-contrib-48a62d1a72190420205c4d7e015c3df092ae66c8.tar.gz
strongswam: disable systemd support in meta-oe and reenable it in meta-systemd
* fixes: strongswan-5.0.0: strongswan: Files/directories were installed but not shipped /lib /lib/systemd /lib/systemd/system /lib/systemd/system/strongswan.service Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb6
-rw-r--r--meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend8
2 files changed, 13 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb b/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb
index 52c8becb0d..efacc8ea4c 100644
--- a/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb
+++ b/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb
@@ -5,7 +5,7 @@ SECTION = "console/network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "gmp openssl flex-native flex bison-native"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"
SRC_URI[md5sum] = "c8b861305def7c0abae04f7bbefec212"
@@ -15,6 +15,10 @@ EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \
--enable-gmp --disable-mysql --disable-sqlite \
--enable-openssl"
+SYSTEMD_UNITDIR ??= "no"
+
+EXTRA_OECONF += "--with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
+
inherit autotools
RRECOMMENDS_${PN} = "kernel-module-ipsec"
diff --git a/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend b/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend
new file mode 100644
index 0000000000..a60a109afd
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend
@@ -0,0 +1,8 @@
+inherit systemd
+
+PRINC := "${@int(PRINC) + 1}"
+
+SYSTEMD_UNITDIR = "${systemd_unitdir}/system"
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "${PN}.service"