aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-04 19:46:46 -0700
committerArmin Kuster <akuster808@gmail.com>2021-08-15 07:09:56 -0700
commitd323115ecd437e397bd504758ba52988900f4747 (patch)
tree1908da0dc821051a15f2d3a18e3af6acb3ebda85
parentec601332b263048407a771faca0087c7efd827f2 (diff)
downloadmeta-openembedded-contrib-d323115ecd437e397bd504758ba52988900f4747.tar.gz
fvwm: Fix build time paths in target perl/python scripts
Add rdeps as needed Fixes shebang-size QA warnings Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 8cc64128c70c5b6a41b050332abb1d73a10ef4fa) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb
index c93c510976..3b01a216bd 100644
--- a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb
+++ b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb
@@ -82,6 +82,9 @@ do_install_append() {
install -d -m 0755 ${D}/${datadir}/fvwm
touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults
+ sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${bindir}/fvwm-*
+ sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${libexecdir}/fvwm/*/Fvwm*
+ sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/fvwm-menu-desktop
}
# the only needed packages (note: locale packages are automatically generated
@@ -113,3 +116,7 @@ FILES_${PN}-doc = " \
RDEPENDS_${PN} = " \
xuser-account \
"
+RDEPENDS_${PN}-extra += "\
+ perl \
+ python3-core \
+"