aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-02 11:30:41 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:56 +0100
commitdcff4339d9deda0b1f70cd882587fec8a887aa91 (patch)
tree12ec98b3c3b49aaf1f7bda1d322ca60b8de5efda
parent32b0092f6f6bb6687633e24ab44cf0f2ab73c810 (diff)
downloadmeta-openembedded-contrib-dcff4339d9deda0b1f70cd882587fec8a887aa91.tar.gz
python-anyjson: add a recipe for version 0.3.3
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-anyjson.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-anyjson_0.3.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-anyjson.inc b/meta-python/recipes-devtools/python/python-anyjson.inc
new file mode 100644
index 0000000000..a0d20ff4d0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-anyjson.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Wraps the best available JSON implementation available in a common interface"
+DESCRIPTION = "Anyjson loads whichever is the fastest JSON module installed and \
+provides a uniform API regardless of which JSON implementation is used."
+HOMEPAGE = "https://bitbucket.org/runeh/anyjson"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08"
+
+inherit pypi
+
+SRC_URI[md5sum] = "2ea28d6ec311aeeebaf993cb3008b27c"
+SRC_URI[sha256sum] = "37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-simplejson"
diff --git a/meta-python/recipes-devtools/python/python-anyjson_0.3.3.bb b/meta-python/recipes-devtools/python/python-anyjson_0.3.3.bb
new file mode 100644
index 0000000000..31b8749fe2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-anyjson_0.3.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-anyjson.inc
diff --git a/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb b/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
new file mode 100644
index 0000000000..199e225b23
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-anyjson.inc