aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2019-12-12 08:25:13 -0600
committerArmin Kuster <akuster@mvista.com>2020-01-11 14:33:05 -0800
commit7a59df2bcc93abc949abf57a40127f9d33acf56b (patch)
tree73f49264f88c511084abf1b4c45aa1513d1ac443
parent95e212124e9a65ae3383baccee52ce104b411f64 (diff)
downloadmeta-openembedded-contrib-7a59df2bcc93abc949abf57a40127f9d33acf56b.tar.gz
wireshark: fix qt5 build
Add qttools-native to PACKAGECONFIG[qt5] DEPENDS to resolve missing Qt5LinguistTools build error. Add qtmultimedia to PACKAGECONFIG[qt5] DEPENDS to resolve missing Qt5Multimedia build error. Add qtsvg to PACKAGECONFIG[qt5] DEPENDS to resolve missing Qt5Svg build error. Inherit cmake_qt5 when qt5 is in PACKAGECONFIG to resolve get_target_property() called with non-existent target "Qt5::qmake" build error. Automatically add qt5 to PACKAGECONFIG when meta-qt5 is in the build since adding qt5 via a .bbappend won't satisfy the conditional inherit cmake_qt5. The poppler recipe does exactly this. Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry-picked from b750c405c7d291a885b8ceb197fe59b2ce125d11, already in zeus) Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb b/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb
index efcd5e42ee..7bb9e23c31 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_3.0.3.bb
@@ -21,7 +21,7 @@ inherit cmake pkgconfig python3native perlnative upstream-version-is-even
ARM_INSTRUCTION_SET = "arm"
-PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
+PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}"
PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh"
@@ -43,7 +43,9 @@ PACKAGECONFIG[lz4] = "-DENABLE_LZ4=ON,-DENABLE_LZ4=OFF, lz4"
# these next two options require addional layers
PACKAGECONFIG[c-ares] = "-DENABLE_CARES=ON,-DENABLE_CARES=OFF, c-ares"
-PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON -DBUILD_wireshark=ON, -DENABLE_QT5=OFF -DBUILD_wireshark=OFF, qtbase"
+PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON -DBUILD_wireshark=ON, -DENABLE_QT5=OFF -DBUILD_wireshark=OFF, qttools-native qtmultimedia qtsvg"
+
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
EXTRA_OECMAKE += "-DENABLE_NETLINK=ON \
-DBUILD_mmdbresolve=OFF \