aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-27 02:24:28 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-11 11:50:56 -0800
commit75356b6a76e965f6e282e8219e88afc1ab4f3240 (patch)
tree6a8fb4def143c0139c7048f42844582175ba902d
parent427184e46a1b9138159f0baa5db497807b0a65a1 (diff)
downloadmeta-openembedded-contrib-75356b6a76e965f6e282e8219e88afc1ab4f3240.tar.gz
mraa: fix build for musl
* be16toh and le16toh are defined in endian.h Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch29
-rw-r--r--meta-oe/recipes-extended/mraa/mraa_git.bb2
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch b/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch
new file mode 100644
index 0000000000..401949e2ec
--- /dev/null
+++ b/meta-oe/recipes-extended/mraa/mraa/0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch
@@ -0,0 +1,29 @@
+From 6c2649718fc9818da0d602a0b4767ea21a367e9e Mon Sep 17 00:00:00 2001
+From: Tim Orling <timothy.t.orling@linux.intel.com>
+Date: Sat, 27 Jan 2018 02:06:36 -0800
+Subject: [PATCH] examples/iio_driver.c: include endian.h to fix musl build
+
+* be16toh and le16toh are defined in endian.h
+
+Upstream-Status: Pending
+
+Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
+---
+ examples/iio_driver.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/examples/iio_driver.c b/examples/iio_driver.c
+index c5a0181..e3dc438 100644
+--- a/examples/iio_driver.c
++++ b/examples/iio_driver.c
+@@ -23,6 +23,7 @@
+ */
+
+ #include <unistd.h>
++#include <endian.h>
+ #include "mraa/iio.h"
+
+ static void
+--
+2.13.6
+
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb
index c4b9c6f90e..e1d593cbee 100644
--- a/meta-oe/recipes-extended/mraa/mraa_git.bb
+++ b/meta-oe/recipes-extended/mraa/mraa_git.bb
@@ -10,6 +10,8 @@ PV = "1.7.0-git${SRCPV}"
SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http"
+SRC_URI_append_libc-musl = " file://0001-examples-iio_driver.c-include-endian.h-to-fix-musl-b.patch"
+
S = "${WORKDIR}/git"
# CMakeLists.txt checks the architecture, only x86 and ARM supported for now