aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-02-26 16:55:55 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-01 11:07:05 -0800
commitbb743fc71d3b0bc22b6c4a6ada44b63c38914dc4 (patch)
tree46122656f8ed2e877155b629fb1af98c9a187657
parent3a97d70decb6dbbfb49a7779881be398f26122ea (diff)
downloadmeta-openembedded-contrib-bb743fc71d3b0bc22b6c4a6ada44b63c38914dc4.tar.gz
python3-semantic-version: Add recipe
Add semantic_version - a library implementing the 'SemVer' scheme. Version 2.8.5 brings: - Properly handle wildcards in SimpleSpec (e.g. ==1.2.*) Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-semantic-version_2.8.5.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-semantic-version_2.8.5.bb b/meta-python/recipes-devtools/python/python3-semantic-version_2.8.5.bb
new file mode 100644
index 0000000000..b8541ff570
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-semantic-version_2.8.5.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A library implementing the 'SemVer' scheme."
+DESCRIPTION = "Semantic version comparison for Python (see http://semver.org/)"
+HOMEPAGE = "https://github.com/rbarrois/python-semanticversion"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2"
+
+SRC_URI[sha256sum] = "d2cb2de0558762934679b9a104e82eca7af448c9f4974d1f3eeccff651df8a54"
+
+PYPI_PACKAGE = "semantic_version"
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"