aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-07 11:45:46 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:45:16 -0700
commitc84226766f387273c4118553e48aea91bbb9f56f (patch)
treed45f0092e8dbf8aa851abc618599c8e3ca5b54b7
parent9c54d36b8e38af99c7552cdfc8a8f34826ec58d6 (diff)
downloadmeta-openembedded-contrib-c84226766f387273c4118553e48aea91bbb9f56f.tar.gz
libstrictures-perl: add 1.005004
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libstrictures/libstrictures-perl_1.005004.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libstrictures/libstrictures-perl_1.005004.bb b/meta-perl/recipes-perl/libstrictures/libstrictures-perl_1.005004.bb
new file mode 100644
index 0000000000..f925d78d3a
--- /dev/null
+++ b/meta-perl/recipes-perl/libstrictures/libstrictures-perl_1.005004.bb
@@ -0,0 +1,41 @@
+SUMMARY = "strictures - turn on strict and make all warnings fatal"
+DESCRIPTION = "I've been writing the equivalent of this module at the top \
+of my code for about a year now. I figured it was time to make it shorter. \
+\
+Things like the importer in \"use Moose\" don't help me because they turn \
+warnings on but don't make them fatal -- which from my point of view is \
+useless because I want an exception to tell me my code isn't warnings-clean. \
+\
+Any time I see a warning from my code, that indicates a mistake. \
+\
+Any time my code encounters a mistake, I want a crash -- not spew to STDERR \
+and then unknown (and probably undesired) subsequent behaviour. \
+\
+I also want to ensure that obvious coding mistakes, like indirect object \
+syntax (and not so obvious mistakes that cause things to accidentally compile \
+as such) get caught, but not at the cost of an XS dependency and not at the \
+cost of blowing things up on another machine. \
+\
+Therefore, \"strictures\" turns on additional checking, but only when it \
+thinks it's running in a test file in a VCS checkout -- although if this \
+causes undesired behaviour this can be overridden by setting the \
+PERL_STRICTURES_EXTRA environment variable."
+
+SECTION = "libs"
+
+HOMEPAGE = "https://metacpan.org/pod/strictures"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=174;endline=180;md5=ccaeb4f589794955aa56c68aea6d38c1"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/strictures-${PV}.tar.gz"
+SRC_URI[md5sum] = "1da9241286818e8d374fb9849d17a13d"
+SRC_URI[sha256sum] = "bbf066cfb37d3ae4b23d1fcf5c7aea276ae3b3b43c5fc7472e1d1880cc063879"
+
+S = "${WORKDIR}/strictures-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-test-more"
+
+BBCLASSEXTEND = "native"