aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-05 10:46:58 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:45:15 -0700
commitd2cf61f7270b8ac2cf50a9183c6ebf5921435f9d (patch)
tree7b1fb21bc9730b1ea488cedfeb5e77063cb79bcc
parentfaf83c51dd4e79419e5dd1abfba96c26a09ac982 (diff)
downloadmeta-openembedded-contrib-d2cf61f7270b8ac2cf50a9183c6ebf5921435f9d.tar.gz
libclass-method-modifiers-perl: add 2.10
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.10.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.10.bb b/meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.10.bb
new file mode 100644
index 0000000000..cc9cac12b8
--- /dev/null
+++ b/meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.10.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Class::Method::Modifiers - provides Moose-like method modifiers"
+DESCRIPTION = "Method modifiers are a convenient feature from the CLOS \
+(Common Lisp Object System) world."
+
+SECTION = "libs"
+
+HOMEPAGE = "https://github.com/moose/Class-Method-Modifiers/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16fd0ec7b73c0e158426f753943f1058"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Class-Method-Modifiers-${PV}.tar.gz"
+SRC_URI[md5sum] = "bd56ab860d1a24e6d9c7e87e36e2b09c"
+SRC_URI[sha256sum] = "420fb53f789f53ecddc17890b0f648289397cceeb2de05f0994999fdf329e7b6"
+
+S = "${WORKDIR}/Class-Method-Modifiers-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-b \
+ perl-module-base \
+ perl-module-carp \
+ perl-module-exporter \
+ perl-module-strict \
+ perl-module-warnings \
+"
+
+BBCLASSEXTEND = "native"