aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-02-23 15:17:17 +0200
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:30:26 -0800
commit3b64db47223006c6f6b4437a278bed0f3b568d42 (patch)
treeeded9419aca2d38b59442eeb617887760bed5d53
parentd076ac1d8f456fe1e07741c28e1f87e1809bcac0 (diff)
downloadmeta-openembedded-contrib-3b64db47223006c6f6b4437a278bed0f3b568d42.tar.gz
python3-ordered-set: Upgrade 4.0.2 -> 4.1.0
Upgrade to release 4.1.0: - Packaged using flit. Wheels now exist, and setuptools is no longer required. - This package now has a typical package structure, instead of being a single module. The code is in ordered_set/__init__.py instead of ordered_set.py. - There is an ordered_set/py.typed so that type checkers know about the types. - Use the type aliases SetLike[T] and OrderedSetInitializer[T] to simplify some types. - Updated the way overloaded type signatures are written to what MyPy currently expects. - Minimum Python version is 3.7. License-Update: Update years Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb (renamed from meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb)7
2 files changed, 4 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
index f7b9d0907c..c27a6c3c57 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest test.py
+pytest test_ordered_set.py
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
index 323fe18fd1..2740b33551 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
@@ -1,10 +1,9 @@
SUMMARY = "A MutableSet that remembers its order, so that every entry has an index."
HOMEPAGE = "http://github.com/LuminosoInsight/ordered-set"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=2b36be0d99854aa2ae292a800a7c1d4e"
+LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=3bf5e1ad64c0d99032c3143361fa234e"
-SRC_URI[md5sum] = "5d88f3870c32d4868b28c8fe833f7e74"
-SRC_URI[sha256sum] = "ba93b2df055bca202116ec44b9bead3df33ea63a7d5827ff8e16738b97f33a95"
+SRC_URI[sha256sum] = "694a8e44c87657c59292ede72891eb91d34131f6531463aab3009191c77364a8"
inherit pypi setuptools3 ptest
@@ -19,5 +18,5 @@ RDEPENDS:${PN}-ptest += " \
"
do_install_ptest() {
- cp -f ${S}/test.py ${D}${PTEST_PATH}/
+ cp -f ${S}/test/test_ordered_set.py ${D}${PTEST_PATH}/
}