aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-07 17:25:12 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-12 12:06:02 +0200
commite33cb25d595e8698c3936410a4ab508125c94d15 (patch)
tree5e0435b99d72aefbdaede2e315db01466f8a77d4
parentd048fd049f154b273b09f86816f8296de11327e5 (diff)
downloadmeta-openembedded-contrib-e33cb25d595e8698c3936410a4ab508125c94d15.tar.gz
portaudio: explicitly disable oss, add PACKAGECONFIG for alsa and jack
* autoenabled dependencies on alsa-lib and jack are breaking espeak when it's built against portaudio in sysroot without them | ld: warning: libasound.so.2, needed by usr/lib/libportaudio.so, not found (try using -rpath or -rpath-link) | ld: warning: libjack.so.0, needed by usr/lib/libportaudio.so, not found (try using -rpath or -rpath-link) | usr/lib/libportaudio.so: undefined reference to `snd_pcm_sw_params_sizeof@ALSA_0.9' | usr/lib/libportaudio.so: undefined reference to `snd_pcm_hw_params_test_period_size@ALSA_0.9' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19_svn.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19_svn.bb b/meta-oe/recipes-support/portaudio/portaudio-v19_svn.bb
index ced4b6b8ff..454bd34082 100644
--- a/meta-oe/recipes-support/portaudio/portaudio-v19_svn.bb
+++ b/meta-oe/recipes-support/portaudio/portaudio-v19_svn.bb
@@ -2,14 +2,21 @@ DESCRIPTION = "A portable audio library"
SECTION = "libs/multimedia"
LICENSE = "PortAudio"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df"
-SRCREV = "1387"
+
PV = "v19+svnr${SRCPV}"
+SRCREV = "1387"
SRC_URI = "svn://subversion.assembla.com/svn/portaudio/portaudio;module=trunk;protocol=http"
S = "${WORKDIR}/trunk"
inherit autotools pkgconfig
+PACKAGECONFIG ??= "alsa jack"
+PACKAGECONFIG[alsa] = "--with-alsa, --without-alsa, alsa-lib,"
+PACKAGECONFIG[jack] = "--with-jack, --without-jack, jack,"
+
+EXTRA_OECONF = "--without-oss"
+
TESTS = " pa_devs patest1 patest_hang patest_many patest_prime patest_sine patest_stop patest_write_sine \
pa_fuzz patest_buffer patest_in_overflow patest_maxsines patest_read_record patest_sine8 patest_sync \
pa_minlat patest_callbackstop patest_latency patest_multi_sine patest_record patest_sine_formats patest_toomanysines \