aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-15 16:55:29 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2019-06-26 09:31:24 -0700
commitaa747a937703e1301e1d7a231382c91e3f98393d (patch)
tree3092e6bdeb9cb36812870ff0c78e0581d6b2e561
parent2a4295f16fdbc578100f8bcd6b3bc019f6600834 (diff)
downloadmeta-openembedded-contrib-aa747a937703e1301e1d7a231382c91e3f98393d.tar.gz
libdbi-perl: fix dependencies
* Fix RDEPENDS, drop class-target (dependencies are the same for native) * Reorganize recipe to best practices * Add ptest dependencies Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb38
1 files changed, 31 insertions, 7 deletions
diff --git a/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb b/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb
index ff4a9d0610..77991bd158 100644
--- a/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb
+++ b/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb
@@ -7,13 +7,6 @@ database interface independent of the actual database being used. \
HOMEPAGE = "http://search.cpan.org/dist/DBI/"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0+"
-RDEPENDS_${PN}_class-target = " \
- perl-module-carp \
- perl-module-exporter \
- perl-module-exporter-heavy \
- perl-module-dynaloader \
-"
-
LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
@@ -34,4 +27,35 @@ do_install_prepend() {
rm -rf ${B}/t/z*.t
}
+RDEPENDS_${PN} = " \
+ perl-module-carp \
+ perl-module-exporter \
+ perl-module-exporter-heavy \
+ perl-module-dynaloader \
+ perl-module-io-dir \
+ perl-module-scalar-util \
+ perl-module-universal \
+"
+
+RDEPENDS_${PN}-ptest = " \
+ ${PN} \
+ perl-module-b \
+ perl-module-benchmark \
+ perl-module-cwd \
+ perl-module-data-dumper \
+ perl-module-encode \
+ perl-module-encode-byte \
+ perl-module-encode-encoding \
+ perl-module-file-copy \
+ perl-module-file-path \
+ perl-module-lib \
+ perl-module-perlio \
+ perl-module-perlio-scalar \
+ perl-module-perlio-via \
+ perl-module-sdbm-file \
+ perl-module-storable \
+ perl-module-test-more \
+ perl-module-utf8 \
+ "
+
BBCLASSEXTEND = "native"