aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-22 16:04:48 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-25 08:32:41 -0700
commit29076c749278d4150d9ec2327b5aefbd6f05309d (patch)
tree3ac0f472de9a613276d76a934d06e00c92d3af0f
parent0b5662a1ed3d0520cfc3a751dd31fb37acc5d4b6 (diff)
downloadmeta-openembedded-contrib-29076c749278d4150d9ec2327b5aefbd6f05309d.tar.gz
crash: Do not build on riscv
Keep mips64 exclusion as well Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.2.8.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb b/meta-oe/recipes-kernel/crash/crash_7.2.8.bb
index 5fc25f400a..834c92cc46 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.2.8.bb
@@ -38,8 +38,12 @@ inherit gettext
BBCLASSEXTEND = "native cross"
TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"
-# crash 7.1.3 and before don't support mips64
-COMPATIBLE_HOST = "^(?!mips64).*"
+# crash 7.1.3 and before don't support mips64/riscv64
+COMPATIBLE_HOST_riscv64 = "null"
+COMPATIBLE_HOST_riscv32 = "null"
+COMPATIBLE_HOST_mipsarchn64 = "null"
+COMPATIBLE_HOST_mipsarchn32 = "null"
+
EXTRA_OEMAKE = 'RPMPKG="${PV}" \
GDB_TARGET="${TARGET_SYS}" \