aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-25 16:23:35 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:47 -0800
commit7db202fdd7de07668ea5b06490a7ca97a96e3622 (patch)
treee9e2d0142fbcd6bb793b39c80266157059b49984
parentd37c0a99d69acacabf8a0d100417ba1c5856efa5 (diff)
downloadmeta-openembedded-contrib-7db202fdd7de07668ea5b06490a7ca97a96e3622.tar.gz
python3-distutils-extra; merge inc, fix wheel build
We have not supported Python2 for quite some time now, so there is no reason to maintain a separate inc file. This recipe does not inherit pypi and the PN does not match the built wheel. Set PIP_INSTALL_PACKAGE appropriately so the wheel can be found. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-oe/recipes-devtools/python/python3-distutils-extra.bb9
-rw-r--r--meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb (renamed from meta-oe/recipes-devtools/python/python-distutils-extra.inc)8
2 files changed, 6 insertions, 11 deletions
diff --git a/meta-oe/recipes-devtools/python/python3-distutils-extra.bb b/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
deleted file mode 100644
index 580842d0d6..0000000000
--- a/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require python-distutils-extra.inc
-
-inherit setuptools3
-
-S = "${WORKDIR}/python-distutils-extra-${PV}"
-
-RDEPENDS:${PN} = "\
- python3-setuptools \
-"
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.inc b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
index 3430cedf63..8aca4ca3ac 100644
--- a/meta-oe/recipes-devtools/python/python-distutils-extra.inc
+++ b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
@@ -5,9 +5,13 @@ SECTION = "devel/python"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4"
-PV = "2.39"
SRC_URI = "https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/python-distutils-extra-${PV}.tar.gz"
-SRC_URI[md5sum] = "16e06db0ef73a35b4bff4b9eed5699b5"
SRC_URI[sha256sum] = "723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae8063af"
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "python_distutils_extra"
+
+S = "${WORKDIR}/python-distutils-extra-${PV}"
+
BBCLASSEXTEND = "native"