aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-25 18:18:45 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:47 -0800
commit86632101d7b54a55632558aa27c2029a896637ad (patch)
tree373406700ac9c110c52668cc0ccddac978c7e221
parent30f1a2ec2bb3f7812345a9369d5e928f5a87a1f8 (diff)
downloadmeta-openembedded-contrib-86632101d7b54a55632558aa27c2029a896637ad.tar.gz
python3-pyserial: also remove /usr/bin/__pycache__
PEP-517 packaging tries to also ship ${bindir}/__pycache__, since we are removing all the scripts from ${bindir}, remove the cache as well. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.5.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
index 4766d92266..15646235df 100644
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pyserial_3.5.bb
@@ -9,6 +9,7 @@ inherit pypi setuptools3 ptest
do_install:append() {
rm -f ${D}${bindir}/pyserial-miniterm
rm -f ${D}${bindir}/pyserial-ports
+ rm -rf ${D}${bindir}/__pycache__
rmdir ${D}${bindir}
}