aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-25 17:48:51 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:47 -0800
commita73411001aff2ba1ba351d44b9f3af6c1a2dba92 (patch)
treed25e6b91f4d305fc5b275afc7ec8ca83cef21a2a
parent7db202fdd7de07668ea5b06490a7ca97a96e3622 (diff)
downloadmeta-openembedded-contrib-a73411001aff2ba1ba351d44b9f3af6c1a2dba92.tar.gz
python3-cvxopt: fix wheel build
This recipe does not inherit pypi nor have a PN pattern that naïvely matches to PN. Set PIP_INSTALL_PACKAGE appropriately. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cvxopt_1.2.7.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cvxopt_1.2.7.bb b/meta-python/recipes-devtools/python/python3-cvxopt_1.2.7.bb
index 1bcf18ab6f..66eb79e6a8 100644
--- a/meta-python/recipes-devtools/python/python3-cvxopt_1.2.7.bb
+++ b/meta-python/recipes-devtools/python/python3-cvxopt_1.2.7.bb
@@ -14,6 +14,8 @@ DEPENDS += "lapack suitesparse"
inherit setuptools3
+PIP_INSTALL_PACKAGE = "cvxopt"
+
export CVXOPT_BLAS_LIB_DIR = "${STAGING_LIBDIR}"
export CVXOPT_SUITESPARSE_LIB_DIR = "${STAGING_LIBDIR}"
export CVXOPT_SUITESPARSE_INC_DIR = "${STAGING_INCDIR}"