aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-27 11:43:30 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:48 -0800
commitb20c58079815206e56b1bdf554ffda9e0aecf5d6 (patch)
treeefa731d0fd7b3f55c9d0904a49dc03b3518bc7bc
parent66207cc163cedafc20a134c13ca071de6b6dd3df (diff)
downloadmeta-openembedded-contrib-b20c58079815206e56b1bdf554ffda9e0aecf5d6.tar.gz
python3-twofish: patch to use setuptools
setup.py bdist_wheel does not work with distutils (which is deprecated anyway). Add a patch to switch to setuptools to allow wheel to be built. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch26
-rw-r--r--meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb6
2 files changed, 30 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch
new file mode 100644
index 0000000000..99e5c6c517
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-twofish/0002-setup.py-switch-to-setuptools.patch
@@ -0,0 +1,26 @@
+From fe10781bd15ed7a5c384dbf121f78f129995aa8f Mon Sep 17 00:00:00 2001
+From: Tim Orling <tim.orling@konsulko.com>
+Date: Sun, 27 Feb 2022 11:02:36 -0800
+Subject: [PATCH] setup.py: switch to setuptools
+
+Upstream-Status: Submitted
+[https://github.com/keybase/python-twofish/pull/9]
+
+Signed-off-by: Tim Orling <tim.orling@konsulko.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index fcc9546..bfc3273 100644
+--- a/setup.py
++++ b/setup.py
+@@ -8,7 +8,7 @@ Copyright (c) 2013 Keybase
+ setup.py - build and package info
+ """
+
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+
+ twofish_module = Extension('_twofish',
+ sources=['twofish-0.3/twofish.c', 'twofish.c'],
diff --git a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
index 94fb71090e..f45772d507 100644
--- a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb
@@ -5,9 +5,11 @@ HOMEPAGE = "http://github.com/keybase/python-twofish"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=33a63abf6d7567b1689d8ce69f00e43b"
-SRC_URI += "file://0001-Fix-missing-return-statements-in-module-stubs.patch"
+SRC_URI += " \
+ file://0001-Fix-missing-return-statements-in-module-stubs.patch \
+ file://0002-setup.py-switch-to-setuptools.patch \
+"
-SRC_URI[md5sum] = "d7d22f16dc4ffa0e3ae2200654033abe"
SRC_URI[sha256sum] = "b09d8bb50d33b23ff34cafb1f9209f858f752935c6a5c901efb92a41acb830fa"
inherit pypi setuptools3