aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-25 19:38:01 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:47 -0800
commite37adcb1361ff4b68d4761ac5675759d01e61c3d (patch)
tree51c749ad09515b7958861ee006f4314af93c7b66
parente0ab01f164ee0ac17d1271c6e5366bb2ea10fdd3 (diff)
downloadmeta-openembedded-contrib-e37adcb1361ff4b68d4761ac5675759d01e61c3d.tar.gz
python3-pillow: fix wheel build
Recipe does not inherit pypi nor would PN resolve to the name of the wheel so we must set PIP_INSTALL_PACKAGE appropriately. The recipe also builds its wheel in ${S}/dist so we must set PIP_INSTALL_DIST_PATH appropriately. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb b/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb
index de3c92c3d3..487e4b54c4 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_9.0.0.bb
@@ -13,6 +13,9 @@ SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
inherit setuptools3
+PIP_INSTALL_PACKAGE = "Pillow"
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+
DEPENDS += " \
zlib \
jpeg \