aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-10-17 10:12:16 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2017-10-22 01:24:42 -0700
commite2d19f695a28ff50885c40c3b1addc7a9e85766c (patch)
tree8a7380be23ace272bb05d5afb15104a42eed8335
parent0913d8029887f025ec8978866ea82cbc6b0db246 (diff)
downloadmeta-openembedded-contrib-e2d19f695a28ff50885c40c3b1addc7a9e85766c.tar.gz
libagg: add recipe for v2.4.0
Anti-Grain Geometry (AGG) is an Open Source, free of charge graphic library, written in industrially standard C++. The terms and conditions of use AGG are described on The License page. AGG doesn't depend on any graphic API or technology. Basically, you can think of AGG as of a rendering engine that produces pixel images in memory from some vectorial data. But of course, AGG can do much more than that. libagg is a dependency of python-matplotlib. Matplotlib bundles the source, but this is generally considered poor practice in the context of embedded. * Add patch to fix/suppress: configure.ac:11: error: automatic de-ANSI-fication support has been removed <build>/tmp/work/i586-poky-linux/libagg/2.4.0-r0/recipe-sysroot-native/usr/share/aclocal-1.15/obsolete.m4:26: AM_C_PROTOTYPES is expanded from... configure.ac:11: the top level autom4te: m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1 autoreconf: aclocal failed with exit status: 1 ERROR: autoreconf execution failed. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch18
-rw-r--r--meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb30
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch b/meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch
new file mode 100644
index 0000000000..46b84077de
--- /dev/null
+++ b/meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch
@@ -0,0 +1,18 @@
+AM_C_PROTOTYPES throws an error, replace with AC_C_PROTOTYPES
+
+Upstream-Status: Pending
+Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
+
+Index: agg-2.4/configure.ac
+===================================================================
+--- agg-2.4.orig/configure.ac
++++ agg-2.4/configure.ac
+@@ -8,7 +8,7 @@ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CXX
+ AC_ISC_POSIX
+-AM_C_PROTOTYPES
++AC_C_PROTOTYPES
+ if test "x$U" != "x"; then
+ AC_MSG_ERROR(Compiler not ANSI compliant)
+ fi
diff --git a/meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb b/meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb
new file mode 100644
index 0000000000..0a4b10116e
--- /dev/null
+++ b/meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb
@@ -0,0 +1,30 @@
+# Recipe created by recipetool
+# This is the basis of a recipe and may need further editing in order to be fully functional.
+# (Feel free to remove these comments when editing.)
+
+# Unable to find any files that looked like license statements. Check the accompanying
+# documentation and source headers and set LICENSE and LIC_FILES_CHKSUM accordingly.
+#
+# NOTE: LICENSE is being set to "CLOSED" to allow you to at least start building - if
+# this is not accurate with respect to the licensing of the software being built (it
+# will not be in most cases) you must specify the correct value before using this
+# recipe for anything other than initial testing/development!
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRC_URI = " \
+ svn://svn.code.sf.net/p/agg/svn/;module=agg-2.4;rev=127;protocol=https \
+ file://0001-fix-configure-ac.patch"
+
+S = "${WORKDIR}/agg-2.4"
+
+DEPENDS = "freetype libsdl libx11"
+
+# NOTE: if this software is not capable of being built in a separate build directory
+# from the source, you should replace autotools with autotools-brokensep in the
+# inherit line
+inherit pkgconfig autotools
+
+# Specify any options you want to pass to the configure script using EXTRA_OECONF:
+EXTRA_OECONF = ""
+