aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-30 01:20:26 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-01 05:45:17 -0700
commit1f6ef41c0658a2900b6d537b5e728bd9f8029461 (patch)
tree58b47e0adfa75754e7f0f0677f45249a97c8518b
parente86355f2a27ab155d0db241a99f099468868a685 (diff)
downloadmeta-openembedded-contrib-1f6ef41c0658a2900b6d537b5e728bd9f8029461.tar.gz
bitwise: Fix build with latest ncurses 6.3+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/bitwise/bitwise_0.42.bb1
-rw-r--r--meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch27
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/bitwise/bitwise_0.42.bb b/meta-oe/recipes-extended/bitwise/bitwise_0.42.bb
index 04d4ca6e40..ebf4b3c5e6 100644
--- a/meta-oe/recipes-extended/bitwise/bitwise_0.42.bb
+++ b/meta-oe/recipes-extended/bitwise/bitwise_0.42.bb
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \
file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \
+ file://0001-Fix-Werror-format-security-errors-with-mvwprintw.patch \
"
SRC_URI[sha256sum] = "d3d43cef47bf8f49e85f7ed381c3eaf1df921ca51805e0962f1a97a517e1d1d2"
diff --git a/meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch b/meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch
new file mode 100644
index 0000000000..ebcb0dd5ee
--- /dev/null
+++ b/meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch
@@ -0,0 +1,27 @@
+From 53237c103b06f58ad9c2ce3914fcc7fe73629f11 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 30 Oct 2021 01:11:33 -0700
+Subject: [PATCH] Fix -Werror=format-security errors with mvwprintw()
+
+Here a non-constant is used as a format string which
+compiler complains about. Fix by using "%s" as format.
+
+Upstream-Status: Submitted [https://github.com/mellowcandle/bitwise/pull/49]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/interactive.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/interactive.c b/src/interactive.c
+index cce418a..2c0b152 100644
+--- a/src/interactive.c
++++ b/src/interactive.c
+@@ -114,7 +114,7 @@ void update_history_win(void)
+ break;
+ }
+
+- mvwprintw(history_win, j, 2, history[history_pos - i].line);
++ mvwprintw(history_win, j, 2, "%s", history[history_pos - i].line);
+ }
+
+ if (g_has_color)