aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-18 12:40:34 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:56:43 -0700
commit9f6e3b69bd6d6030858c204033a56a58cdb0b1a1 (patch)
tree4d35317cb377b134d9b984a07c02f3edf33a3fb2
parent19ce6fd7bf0b602ace69657bf3e8cda94b09982b (diff)
downloadmeta-openembedded-contrib-9f6e3b69bd6d6030858c204033a56a58cdb0b1a1.tar.gz
python3-bitarray: Upgrade 2.2.5 -> 2.3.0
Upgrade to release 2.3.0: - add optional `buffer` argument to `bitarray()` to import the buffer of another object - update `.buffer_info()` to include: a read-only flag, an imported buffer flag, and the number of buffer exports - add optional start and stop arguments to `util.rindex()` - add [memory-mapped file](../examples/mmapped-file.py) example - ignore underscore (`_`) in string input, e.g. `bitarray('1100_0111')` - add missing type hinting for new `.bytereverse()` arguments - fix `.extend()` type annotations, #145 - avoid `.reverse()` using temporary memory - make `.unpack()`, `util.serialize()`, `util.vl_encode()` and `.__reduce__()` more memory efficient - add and improve tests Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_2.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-bitarray_2.2.5.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_2.2.5.bb b/meta-python/recipes-devtools/python/python3-bitarray_2.3.0.bb
index f8e2489070..b198b47004 100644
--- a/meta-python/recipes-devtools/python/python3-bitarray_2.2.5.bb
+++ b/meta-python/recipes-devtools/python/python3-bitarray_2.3.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/ilanschnell/bitarray"
LICENSE = "PSF"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d"
-SRC_URI[sha256sum] = "efb2dc83f0acb832a94af3687eea558d72512cf2e54a64fca56a10aacf57934c"
+SRC_URI[sha256sum] = "21f2e10420f9ae74d3bdfd3cb74947ddbe9fbc0b2e5662f2f039001954f1d8b6"
inherit setuptools3 pypi