aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-23 16:11:48 -0700
committerTim Orling <ticotimo@gmail.com>2021-08-24 10:11:23 -0700
commit858bcac5be7c9638be8ce7e8cffe469575fa36a8 (patch)
treef5e746950d17f8a43ad320e226f5917d0a72cae2
parent88c67feaf1c3635ad954fcb55289c74227aee3bb (diff)
downloadmeta-openembedded-contrib-858bcac5be7c9638be8ce7e8cffe469575fa36a8.tar.gz
python3-cryptography: upgrade 3.3.2 -> 3.4.7timo/python3-cryptography_no_rust
RDEPENDS on python3-hypothesis (in oe-core) for ptest so we can drop the patch for skipping. Use the CRYPTOGRAPHY_DONT_BUILD_RUST=1 hammer for now, since rust support in oe-core is not ready yet. An alternative would be to move recipe to dynamic-layers and depend on meta-rust, which would also require python3-setuptools-rust in same dynamic layer. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/h-test.patch10
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb (renamed from meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb)7
2 files changed, 5 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
deleted file mode 100644
index 9f07c73803..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/tests/hypothesis/__init__.py
-+++ b/tests/hypothesis/__init__.py
-@@ -3,3 +3,7 @@
- # for complete details.
-
- from __future__ import absolute_import, division, print_function
-+
-+import pytest
-+hypothesis = pytest.importorskip("hypothesis")
-+
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb
index baec105a3e..8781c80870 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb
@@ -6,15 +6,17 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba"
LDSHARED += "-pthread"
-SRC_URI[sha256sum] = "5a60d3780149e13b7a6ff7ad6526b38846354d11a15e21068e57073e29e19bed"
+SRC_URI[sha256sum] = "3d10de8116d25649631977cb37da6cbdd2d6fa0e0281d014a5b7d337255ca713"
SRC_URI += " \
file://run-ptest \
- file://h-test.patch \
"
inherit pypi setuptools3
+# We don't have rust support in oe-core yet
+export CRYPTOGRAPHY_DONT_BUILD_RUST=1
+
DEPENDS += " \
${PYTHON_PN}-cffi \
${PYTHON_PN}-cffi-native \
@@ -43,6 +45,7 @@ RDEPENDS:${PN}:class-target += " \
RDEPENDS:${PN}-ptest += " \
${PN} \
${PYTHON_PN}-cryptography-vectors \
+ ${PYTHON_PN}-hypothesis \
${PYTHON_PN}-iso8601 \
${PYTHON_PN}-pretend \
${PYTHON_PN}-pytest \