aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-13 18:12:19 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:37:48 -0700
commit161072d8002d0307011dd626922f673c18cfcd20 (patch)
tree17ad0b1fff7585a39cc03975305420e5225a9ffb
parent7683c1a60642ad93248b2226f4aa2a59e8243063 (diff)
downloadmeta-openembedded-contrib-161072d8002d0307011dd626922f673c18cfcd20.tar.gz
mg: Upgrade to 20200723 tag
Fixes build with gcc10 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/mg/mg/0001-Undefine-REGEX-for-musl-based-systems.patch19
-rw-r--r--meta-oe/recipes-support/mg/mg/0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch5
-rw-r--r--meta-oe/recipes-support/mg/mg/0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch11
-rw-r--r--meta-oe/recipes-support/mg/mg_20200723.bb (renamed from meta-oe/recipes-support/mg/mg_20170401.bb)7
4 files changed, 13 insertions, 29 deletions
diff --git a/meta-oe/recipes-support/mg/mg/0001-Undefine-REGEX-for-musl-based-systems.patch b/meta-oe/recipes-support/mg/mg/0001-Undefine-REGEX-for-musl-based-systems.patch
index 1302679315..9c154a1734 100644
--- a/meta-oe/recipes-support/mg/mg/0001-Undefine-REGEX-for-musl-based-systems.patch
+++ b/meta-oe/recipes-support/mg/mg/0001-Undefine-REGEX-for-musl-based-systems.patch
@@ -9,31 +9,24 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Makefile | 2 +-
2 files changed, 1 insertion(+), 2 deletions(-)
-diff --git a/GNUmakefile b/GNUmakefile
-index 7bf7dca..0e10030 100644
--- a/GNUmakefile
+++ b/GNUmakefile
-@@ -41,7 +41,6 @@ endif
+@@ -45,7 +45,6 @@ endif
CC?= gcc
CFLAGS?= -O2 -pipe
CFLAGS+= -g -Wall
-CPPFLAGS= -DREGEX
CPPFLAGS+= -D_GNU_SOURCE
- CPPFLAGS+= $(BSD_CPPFLAGS) -D__dead=__dead2
+ CPPFLAGS+= $(BSD_CPPFLAGS)
LIBS= $(CURSES_LIBS) $(BSD_LIBS)
-diff --git a/Makefile b/Makefile
-index 94ce340..d516bbc 100644
--- a/Makefile
+++ b/Makefile
-@@ -10,7 +10,7 @@ DPADD+= ${LIBCURSES} ${LIBUTIL}
- # REGEX -- create regular expression functions.
+@@ -11,7 +11,7 @@ DPADD+= ${LIBUTIL}
# STARTUPFILE -- look for and handle initialization file.
+ # MGLOG -- debug mg internals to a log file.
#
--CFLAGS+=-Wall -DREGEX
-+CFLAGS+=-Wall
+-CFLAGS+=-Wall -DREGEX `pkg-config --cflags-only-I ncurses`
++CFLAGS+=-Wall `pkg-config --cflags-only-I ncurses`
SRCS= autoexec.c basic.c bell.c buffer.c cinfo.c dir.c display.c \
echo.c extend.c file.c fileio.c funmap.c help.c kbd.c keymap.c \
---
-2.12.2
-
diff --git a/meta-oe/recipes-support/mg/mg/0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch b/meta-oe/recipes-support/mg/mg/0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch
index 551f1df163..8e8c2b9025 100644
--- a/meta-oe/recipes-support/mg/mg/0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch
+++ b/meta-oe/recipes-support/mg/mg/0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch
@@ -8,8 +8,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
fileio.c | 1 +
1 file changed, 1 insertion(+)
-diff --git a/fileio.c b/fileio.c
-index 48a67a2..9b69665 100644
--- a/fileio.c
+++ b/fileio.c
@@ -12,6 +12,7 @@
@@ -20,6 +18,3 @@ index 48a67a2..9b69665 100644
#include <dirent.h>
#include <errno.h>
#include <fcntl.h>
---
-2.12.2
-
diff --git a/meta-oe/recipes-support/mg/mg/0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch b/meta-oe/recipes-support/mg/mg/0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch
index 907d67064a..bdd7632be6 100644
--- a/meta-oe/recipes-support/mg/mg/0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch
+++ b/meta-oe/recipes-support/mg/mg/0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch
@@ -8,13 +8,11 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
fileio.c | 4 ++++
1 file changed, 4 insertions(+)
-diff --git a/fileio.c b/fileio.c
-index 9b69665..a852fd2 100644
--- a/fileio.c
+++ b/fileio.c
-@@ -28,6 +28,10 @@
- #include "kbd.h"
- #include "pathnames.h"
+@@ -36,6 +36,10 @@
+ #define DEFFILEMODE 0666
+ #endif
+#if !defined(DEFFILEMODE)
+# define DEFFILEMODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH)/* 0666*/
@@ -23,6 +21,3 @@ index 9b69665..a852fd2 100644
static char *bkuplocation(const char *);
static int bkupleavetmp(const char *);
---
-2.12.2
-
diff --git a/meta-oe/recipes-support/mg/mg_20170401.bb b/meta-oe/recipes-support/mg/mg_20200723.bb
index dad1d008bf..b73f937565 100644
--- a/meta-oe/recipes-support/mg/mg_20170401.bb
+++ b/meta-oe/recipes-support/mg/mg_20200723.bb
@@ -5,15 +5,16 @@ LIC_FILES_CHKSUM = "file://version.c;md5=1895eb37bf6bd79cdc5c89d8166fabfb"
DEPENDS = "ncurses libbsd"
SECTION = "console/editors"
-SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz \
+SRCREV = "60fa3582f5f735b9d43825f5bdcc4ea5f0740f91"
+SRC_URI = "git://github.com/hboetes/mg \
file://0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch \
file://0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch \
"
SRC_URI_append_libc-musl = "\
file://0001-Undefine-REGEX-for-musl-based-systems.patch \
"
-SRC_URI[md5sum] = "884388589fb38c2109ad9fed328be20a"
-SRC_URI[sha256sum] = "0a3608b17c153960cb1d954ca3b62445a77c0c1a18aa5c8c58aba9f6b8d62aab"
+
+S = "${WORKDIR}/git"
# CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?=
EXTRA_OEMAKE = "\