aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-23 16:31:42 -0700
committerTim Orling <timothy.t.orling@intel.com>2021-10-02 16:03:00 +0000
commitd2274628c0463b57a3d0578dfb6b62560dd5b22e (patch)
treec0cc77c4271b94db83509f51bd9b01af2ae9db79
parent037f38cc68aabb9e36e92862af258f46874e0c13 (diff)
downloadmeta-openembedded-contrib-d2274628c0463b57a3d0578dfb6b62560dd5b22e.tar.gz
python3-setuptools-rust-native: add 0.12.1
Dependency for python3-cryptography 3.4.x Only native rustc is supported at this time in oe-core, therefore it makes no sense to try to build for target. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb b/meta-python/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb
new file mode 100644
index 0000000000..a0025acfa5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-setuptools-rust-native_0.12.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Setuptools Rust extension plugin"
+HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
+
+SRC_URI[sha256sum] = "647009e924f0ae439c7f3e0141a184a69ad247ecb9044c511dabde232d3d570e"
+SRC_URI[sha384sum] = "2162e5e347ded97c849466da40fb17907648e848ee663c09caad316349caca9648dc73161d747ac91535a4120d8706b5"
+SRC_URI[sha512sum] = "02dc2e2c91533ae847cfe7be0e7b0816fb376405f979c9767ba415c0223aa57429f1c038eb6c06ac9ec3950738b55026fbc6d4c8a8d938cf58a975d40d84cdb8"
+
+inherit cargo pypi setuptools3 native
+
+DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
+
+RDEPENDS:${PN}:class-native += " \
+ python3-semantic-version-native \
+ python3-setuptools-native \
+ python3-setuptools-scm-native \
+ python3-toml-native \
+ python3-wheel-native \
+"