aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-09-23 22:31:50 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-24 08:12:36 -0700
commitd7d9597348534b9d93dd7ed8ef49fa2b5c33969d (patch)
tree922adb386961e7b2f8d1775296aaf9f5276fbfb9
parentce9a5941f90a4e2c0514df7503786cbc2188d08e (diff)
downloadmeta-openembedded-contrib-d7d9597348534b9d93dd7ed8ef49fa2b5c33969d.tar.gz
protobuf: upgrade 3.17.3 -> 3.18.0
C++ Fix warnings raised by clang 11 (#8664) Make StringPiece constructible from std::string_view (#8707) Add missing capability attributes for LLVM 12 (#8714) Stop using std::iterator (deprecated in C++17). (#8741) Move field_access_listener from libprotobuf-lite to libprotobuf (#8775) Fix #7047 Safely handle setlocale (#8735) Remove deprecated version of SetTotalBytesLimit() (#8794) Support arena allocation of google::protobuf::AnyMetadata (#8758) Fix undefined symbol error around SharedCtor() (#8827) Fix default value of enum(int) in json_util with proto2 (#8835) Better Smaller ByteSizeLong Introduce event filters for inject_field_listener_events Reduce memory usage of DescriptorPool For lazy fields copy serialized form when allowed. Re-introduce the InlinedStringField class v2 access listener Reduce padding in the proto's ExtensionRegistry map. GetExtension performance optimizations Make tracker a static variable rather than call static functions Support extensions in field access listener Annotate MergeFrom for field access listener Fix incomplete types for field access listener Add map_entry/new_map_entry to SpecificField in MessageDifferencer. They record the map items which are different in MessageDifferencer's reporter. Reduce binary size due to fieldless proto messages TextFormat: ParseInfoTree supports getting field end location in addition to start. Fix repeated enum extension size in field listener Enable Any Text Expansion for Descriptors::DebugString() Switch from int{8,16,32,64} to int{8,16,32,64}_t Java Fix errorprone conflict (#8723) Removing deprecated TimeUtil class. (#8749) Optimized FieldDescriptor.valueOf() to avoid array copying. Removing deprecated TimeUtil class. Add Durations.parseUnchecked(String) and Timestamps.parseUnchecked(String) FieldMaskUtil: Add convenience method to mask the fields out of a given proto. JavaScript Optimize binary parsing of repeated float64 Fix for optimization when reading doubles from binary wire format Replace toArray implementation with toJSON. PHP Migrate PHP & Ruby to ABSL wyhash (#8854) Added support for PHP 8.1 (currently in RC1) to the C extension (#8964) Fixed PHP SEGV when constructing messages from a destructor. (#8969) Ruby Move DSL implementation from C to pure Ruby (#8850) Fixed a memory bug with RepeatedField#+. (#8970) Python Drops support for 2.7 and 3.5. Other [csharp] ByteString.CreateCodedInput should use ArraySegment offset and count (#8740) [ObjC] Add support for using the proto package to prefix symbols. (#8760) field_presence.md: fix Go example (#8788) Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf/0001-Makefile.am-include-descriptor.cc-when-building-libp.patch12
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.18.0.bb (renamed from meta-oe/recipes-devtools/protobuf/protobuf_3.17.3.bb)6
2 files changed, 10 insertions, 8 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf/0001-Makefile.am-include-descriptor.cc-when-building-libp.patch b/meta-oe/recipes-devtools/protobuf/protobuf/0001-Makefile.am-include-descriptor.cc-when-building-libp.patch
index fc7286122c..bd3a277a3d 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf/0001-Makefile.am-include-descriptor.cc-when-building-libp.patch
+++ b/meta-oe/recipes-devtools/protobuf/protobuf/0001-Makefile.am-include-descriptor.cc-when-building-libp.patch
@@ -1,7 +1,8 @@
-From 321709837f412e2f590e36e3fe33571bb40036a7 Mon Sep 17 00:00:00 2001
+From 8515ceec5ba3e2fcdbc819b5bf10fe742d7c9d5d Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Thu, 27 Jun 2019 13:27:18 +0000
-Subject: [PATCH] Makefile.am: include descriptor.pb.cc when building libprotoc.so
+Subject: [PATCH] Makefile.am: include descriptor.pb.cc when building
+ libprotoc.so
* otherwise plugin.pb.o has undefined symbol scc_info_FileDescriptorProto_google_2fprotobuf_2fdescriptor_2eproto
and build with gold fails with:
@@ -10,19 +11,20 @@ Subject: [PATCH] Makefile.am: include descriptor.pb.cc when building libprotoc.s
Upstream-Status: Pending
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
---
src/Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/Makefile.am b/src/Makefile.am
-index be18ba761..57e3daec1 100644
+index d4f11ce79..96d911746 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -313,6 +313,7 @@ libprotoc_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libprotoc.map
+@@ -323,6 +323,7 @@ libprotoc_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libprotoc.map
EXTRA_libprotoc_la_DEPENDENCIES = libprotoc.map
endif
libprotoc_la_SOURCES = \
+ google/protobuf/descriptor.pb.cc \
google/protobuf/compiler/code_generator.cc \
google/protobuf/compiler/command_line_interface.cc \
- google/protobuf/compiler/plugin.cc \
+ google/protobuf/compiler/cpp/cpp_enum.cc \
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.17.3.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.18.0.bb
index 4de2c93d40..9f501124a0 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_3.17.3.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.18.0.bb
@@ -10,14 +10,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b"
DEPENDS = "zlib"
DEPENDS:append:class-target = " protobuf-native"
-SRCREV = "909a0f36a10075c4b4bc70fdee2c7e32dd612a72"
+SRCREV = "89b14b1d16eba4d44af43256fc45b24a6a348557"
-SRC_URI = "git://github.com/protocolbuffers/protobuf.git \
+SRC_URI = "git://github.com/protocolbuffers/protobuf.git;branch=3.18.x \
file://run-ptest \
file://0001-protobuf-fix-configure-error.patch \
file://0001-Makefile.am-include-descriptor.cc-when-building-libp.patch \
file://0001-examples-Makefile-respect-CXX-LDFLAGS-variables-fix-.patch \
-"
+ "
S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig ptest