aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-01-03 13:17:16 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-05 11:10:02 -0800
commit466ffb841427ac2ccba1d1b7d05f8b01546b947d (patch)
tree511e5d597f90e4cdc2086070194af4a0bbf5a78c
parent0a1f6a9879dbd1c8806bff9b723ee00316abfb60 (diff)
downloadmeta-openembedded-contrib-466ffb841427ac2ccba1d1b7d05f8b01546b947d.tar.gz
pkcs11-helper: upgrade 1.27 -> 1.28
0001-build-openssl-remove-RSA_SSLV23_PADDING-constant-usa.patch 0001-nss-use-nss-pkcs11-h.patch removed since they're included in 1.28. Changelog: ========= * build: openssl: remove RSA_SSLV23_PADDING constant usage due to openssl-3 compatibility. * build: nss: use nss pkcs11.h * build: windows: checksum in PE * build: windows: support openssl-1.1.1 * mbed: require >=mbedtls-2, mbed dropped polarssl compatibility, * certificate: add methods accept full mechanism * core: load provider library as private. * core: add pkcs11h_getProperty, pkcs11h_setProperty to support adding properties without breaking API. * core: add pkcs11h_initializeProvider, pkcs11h_registerProvider, pkcs11h_setProviderProperty, pkcs11h_setProviderPropertyByName to support adding properties without breaking API * core: add initialization arguments property * core: add PKCS11H_PROVIDER_PROPERTY_PROVIDER_DESTRUCT_HOOK. * session: respect login required token flag. * certificate: respect always authenticate flag. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-build-openssl-remove-RSA_SSLV23_PADDING-constant-usa.patch27
-rw-r--r--meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-nss-use-nss-pkcs11-h.patch61
-rw-r--r--meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.28.bb (renamed from meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.27.bb)7
3 files changed, 2 insertions, 93 deletions
diff --git a/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-build-openssl-remove-RSA_SSLV23_PADDING-constant-usa.patch b/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-build-openssl-remove-RSA_SSLV23_PADDING-constant-usa.patch
deleted file mode 100644
index f2baae9149..0000000000
--- a/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-build-openssl-remove-RSA_SSLV23_PADDING-constant-usa.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 5b9a8da964ee0b998955cd986000cfa27cfa698d Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Wed, 4 Aug 2021 19:02:34 +0300
-Subject: [PATCH] build: openssl: remove RSA_SSLV23_PADDING constant usage
-
-Due to openssl-3 compatibility, thanks to t0b3
-
-Upstream-Status: Backport
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- lib/pkcs11h-openssl.c | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/lib/pkcs11h-openssl.c b/lib/pkcs11h-openssl.c
-index 9c9b2cd..85c8193 100644
---- a/lib/pkcs11h-openssl.c
-+++ b/lib/pkcs11h-openssl.c
-@@ -474,9 +474,6 @@ __pkcs11h_openssl_rsa_dec (
- case RSA_PKCS1_OAEP_PADDING:
- mech = CKM_RSA_PKCS_OAEP;
- break;
-- case RSA_SSLV23_PADDING:
-- rv = CKR_MECHANISM_INVALID;
-- break;
- case RSA_NO_PADDING:
- mech = CKM_RSA_X_509;
- break;
diff --git a/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-nss-use-nss-pkcs11-h.patch b/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-nss-use-nss-pkcs11-h.patch
deleted file mode 100644
index 3070fc41a0..0000000000
--- a/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper/0001-nss-use-nss-pkcs11-h.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 083a3a62f2e631deec2fb2799d10660a41c50294 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Fri, 30 Jul 2021 20:06:36 +0300
-Subject: [PATCH] nss: use nss pkcs11.h
-
-make nss happy with its own extensions and non-standard behavior.
-
-Taken from Archlinux [1]
-
-[1] https://github.com/archlinux/svntogit-packages/commit/238f5e90946f527b2d4a507e02c30e977db38a97
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- lib/_pkcs11h-crypto-nss.c | 14 ++++++++++----
- lib/common.h | 7 +++++++
- 2 files changed, 17 insertions(+), 4 deletions(-)
-
---- a/lib/_pkcs11h-crypto-nss.c
-+++ b/lib/_pkcs11h-crypto-nss.c
-@@ -48,15 +48,21 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include "common.h"
--
--#include "_pkcs11h-crypto.h"
-+#ifdef HAVE_CONFIG_H
-+#include <config.h>
-+#endif
-
- #if defined(ENABLE_PKCS11H_ENGINE_NSS)
--#define _PKCS11T_H_ /* required so no conflict with ours */
- #include <nss.h>
- #include <cert.h>
-
-+/* Use PKCS#11 of nss to avoid conflicts and make nss happy with its own extensions */
-+#define PKCS11_H 1
-+
-+#include "common.h"
-+
-+#include "_pkcs11h-crypto.h"
-+
- static
- int
- __pkcs11h_crypto_nss_initialize (
---- a/lib/common.h
-+++ b/lib/common.h
-@@ -72,5 +72,12 @@
-
- #define _PKCS11H_ASSERT assert
-
-+#ifndef FALSE
-+#define FALSE 0
-+#endif
-+#ifndef TRUE
-+#define TRUE 1
-+#endif
-+
- #endif
-
diff --git a/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.27.bb b/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.28.bb
index 389d1bc7bb..afad03c9a6 100644
--- a/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.27.bb
+++ b/meta-oe/recipes-crypto/pkcs11-helper/pkcs11-helper_1.28.bb
@@ -15,14 +15,11 @@ LIC_FILES_CHKSUM = " \
file://COPYING.GPL;md5=8a71d0475d08eee76d8b6d0c6dbec543 \
file://COPYING.BSD;md5=66b7a37c3c10483c1fd86007726104d7 \
"
-SRC_URI = "git://github.com/OpenSC/${BPN}.git;branch=master;protocol=https \
- file://0001-build-openssl-remove-RSA_SSLV23_PADDING-constant-usa.patch \
- file://0001-nss-use-nss-pkcs11-h.patch \
- "
+SRC_URI = "git://github.com/OpenSC/${BPN}.git;branch=master;protocol=https"
S = "${WORKDIR}/git"
# v1.27
-SRCREV = "564a582d600c7eec7b8e303a22b575fd52622174"
+SRCREV = "a4b46d545c33459610d4b4ae85a43a76e03a8c5e"
UPSTREAM_CHECK_GITTAGREGEX = "pkcs11-helper-(?P<pver>\d+(\.\d+)+)"