aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-01-15 11:45:26 -0800
committerTim Orling <tim.orling@konsulko.com>2022-01-16 08:58:36 -0800
commite543d6a2c78aae65beb613f6bb449cc8164a065d (patch)
tree2244702477bc316c7c5a566a2351d76d80f87e04
parent9b0261d874d90a210ce08286a4798153c189d459 (diff)
downloadmeta-openembedded-contrib-e543d6a2c78aae65beb613f6bb449cc8164a065d.tar.gz
python3-pytest-xdist: add recipe for v2.5.0
The pytest-xdist plugin extends pytest with new test execution modes, the most used being distributing tests across multiple CPUs to speed up test execution: pytest -n auto With this call, pytest will spawn a number of workers processes equal to the number of available CPUs, and distribute the tests randomly across them. There is also a number of distribution modes to choose from. NOTE: due to how pytest-xdist is implemented, the -s/--capture=no option does not work. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
new file mode 100644
index 0000000000..fe9b039ed2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "pytest xdist plugin for distributed testing and loop-on-failing modes"
+DESCRIPTION = "The pytest-xdist plugin extends pytest with new test \
+execution modes, the most used being distributing tests across multiple CPUs \
+to speed up test execution: \
+\
+pytest -n auto \
+\
+With this call, pytest will spawn a number of workers processes equal to \
+the number of available CPUs, and distribute the tests randomly across them. \
+There is also a number of distribution modes to choose from. \
+\
+NOTE: due to how pytest-xdist is implemented, the -s/--capture=no option does not work."
+HOMEPAGE = "https://github.com/pytest-dev/pytest-xdist"
+BUGTRACKER = "https://github.com/pytest-dev/pytest-xdist/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
+
+SRC_URI[sha256sum] = "4580deca3ff04ddb2ac53eba39d76cb5dd5edeac050cb6fbc768b0dd712b4edf"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += "python3-execnet python3-pytest python3-pytest-forked"
+
+RDEPENDS:${PN}:append:class-target = " python3-unixadmin"
+
+BBCLASSEXTEND = "native nativesdk"