aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanacar, StefanX <stefanx.stanacar@intel.com>2014-03-24 19:06:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-29 22:39:50 +0100
commit24afc0aaa5c6018624f4e0ed7b0ae530ae6e0936 (patch)
treed5775d0c537eccff4a8ff126d7716308dcc30617
parenta600fe808a71ad569697eb4921b3d101f1c032d7 (diff)
downloadmeta-openembedded-contrib-24afc0aaa5c6018624f4e0ed7b0ae530ae6e0936.tar.gz
efivar: add recipe
efivar is is a tool to manipulate UEFI variables. This is obviously useful only for EFI machines that have the efivarfs interface enabled in the kernel config (CONFIG_EFIVAR_FS), and mounted (mount -t efivarfs efivarfs /sys/firmware/efi/efivars). Sample usage: GUID: 4a67b082-0a4c-41cf-b6c7-440b29bb8c4f Name: "LoaderEntrySelected" Attributes: Boot Service Access Runtime Service Access Value: 00000000 62 00 6f 00 6f 00 74 00 00 00 |b.o.o.t... | Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/efivar/efivar_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/efivar/efivar_git.bb b/meta-oe/recipes-extended/efivar/efivar_git.bb
new file mode 100644
index 0000000000..18446a08a1
--- /dev/null
+++ b/meta-oe/recipes-extended/efivar/efivar_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Tools to manipulate UEFI variables"
+DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
+HOMEPAGE = "https://github.com/vathpela/efivar"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+DEPENDS = "popt"
+
+SRCREV = "c9e1f24a81b5374408bca5616402276e47171cf7"
+PV = "0.7+git${SRCPV}"
+SRC_URI = "git://github.com/vathpela/efivar.git"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}