aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-01-30 10:05:50 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-02-19 13:12:36 +0000
commit90045a49e50eb0177a8aee5cc318caf037ac603d (patch)
treea974257da50e3b0ae6da7e401ff5c0e191a5ee53
parent398f30aa0689e483ae196cc035643a854d169947 (diff)
downloadmeta-openembedded-contrib-90045a49e50eb0177a8aee5cc318caf037ac603d.tar.gz
dracut: update to 036
* Patch was applied upstream, delete it * Add coreutils dep to stop scripts from erroring out * bump PE to since 'git' > '036' Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch39
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb13
2 files changed, 8 insertions, 44 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch b/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
deleted file mode 100644
index 7dc62ded76..0000000000
--- a/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From c92ea797c43aa811e98b6bd8fb4aae921fa08592 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Fri, 10 Jan 2014 21:11:40 +0100
-Subject: [PATCH] Use builtin xz/lzma option to use all cores for multihreaded
- compression
-
-This removes the dependency on 'getconf' as well, which is not installed by default on my embedded systems.
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-Upstream-status: Submitted
-
----
- dracut.sh | 6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/dracut.sh b/dracut.sh
-index 11dcd0e..2e6ea67 100755
---- a/dracut.sh
-+++ b/dracut.sh
-@@ -697,14 +697,12 @@ stdloglvl=$((stdloglvl + verbosity_mod_l))
- # eliminate IFS hackery when messing with fw_dir
- fw_dir=${fw_dir//:/ }
-
--cpu_count=$(getconf _NPROCESSORS_ONLN)
--
- # handle compression options.
- [[ $compress ]] || compress="gzip"
- case $compress in
- bzip2) compress="bzip2 -9";;
-- lzma) compress="lzma -9 ${cpu_count:+-T$cpu_count}";;
-- xz) compress="xz --check=crc32 --lzma2=dict=1MiB ${cpu_count:+-T$cpu_count}";;
-+ lzma) compress="lzma -9 -T0";;
-+ xz) compress="xz --check=crc32 --lzma2=dict=1MiB -T0";;
- gzip) compress="gzip -9"; command -v pigz > /dev/null 2>&1 && compress="pigz -9";;
- lzo) compress="lzop -9";;
- lz4) compress="lz4 -9";;
---
-1.8.0
-
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
index ccc4e7d6b3..945ba0f21c 100644
--- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -4,10 +4,12 @@ DESCRIPTION = "Dracut is an event driven initramfs infrastructure. dracut (the t
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRCREV = "bb1ba3a1ca9dd6284f6319eb197de4a757a7f99d"
-SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git \
- file://0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch \
- "
+PE = "1"
+PV = "036"
+
+# v036 tag
+SRCREV = "d50a99c5ceeb7107f624c5d3238d37509b2217a8"
+SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git"
S = "${WORKDIR}/git"
@@ -34,5 +36,6 @@ FILES_${PN} += "${datadir}/bash-completion \
RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid bash ldd"
# This could be optimized a bit, but let's avoid non-booting systems :)
RRECOMMENDS_${PN} = " \
- kernel-modules \
+ kernel-modules \
+ coreutils \
"