aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-06-18 14:32:22 +0800
committerJoe MacDonald <joe.macdonald@windriver.com>2013-06-18 10:08:23 -0400
commitbb84e59036b350e29fe96e9aaa0614147d268fb9 (patch)
treebdcacec159f4928b21e845ae762c31237a155503
parenta4c953b35d082c9ef45c6e41212bf9c8f7b0ff74 (diff)
downloadmeta-openembedded-contrib-bb84e59036b350e29fe96e9aaa0614147d268fb9.tar.gz
autofs: two fixes
autofs's lib sources have a dependency on a number of files that are generated by rpcgen during buildtime. fix a typo in configure.in Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-fix-lib-deps.patch28
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb2
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-fix-lib-deps.patch b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-fix-lib-deps.patch
new file mode 100644
index 0000000000..09fea495df
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-fix-lib-deps.patch
@@ -0,0 +1,28 @@
+From 54a9bd28a307dd74df044d779ca85adcf36aa202 Mon Sep 17 00:00:00 2001
+From: Joe MacDonald <joe.macdonald@windriver.com>
+Date: Tue, 18 Jun 2013 10:05:21 -0400
+Subject: [PATCH] Fix the dependency issue
+
+Upstream-Status: Pending
+
+autofs's lib sources have a dependency on a number of files that are
+generated by rpcgen during buildtime
+
+Signed-off-by: Roy.Li <rongqing.li@windriver.com>
+Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
+---
+ lib/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/Makefile b/lib/Makefile
+index 5418009..bff4e1d 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -75,3 +75,4 @@ install: all
+ clean:
+ rm -f $(LIB) $(RPCS) $(OBJS) $(YACCSRC) *.output *~
+
++$(OBJS): $(RPCS)
+--
+1.7.10.4
+
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
index 74a4e68e2d..0c66ebc3d9 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
@@ -59,6 +59,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.bz2 \
file://libtirpc-name-clash-backout.patch \
file://autofs-5.0.7-do-not-check-for-modprobe.patch \
file://fix_disable_ldap.patch \
+ file://autofs-5.0.7-fix-lib-deps.patch \
"
SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431"
@@ -87,6 +88,7 @@ CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
"
do_configure_prepend () {
+ sed -e "s:filagdir:flagdir:" -i configure.in
if [ ! -e acinclude.m4 ]; then
cp aclocal.m4 acinclude.m4
fi