aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-03-27 17:52:55 +0800
committerJoe MacDonald <joe.macdonald@windriver.com>2014-03-27 15:41:12 -0400
commitc1d420a3b65538f80601411f85295db8f4cb30ab (patch)
tree87bd1e84186e854d52c23a4bdbd182105f5dd493
parent6d121827702369b875cb7fa47303117ea74bc96f (diff)
downloadmeta-openembedded-contrib-c1d420a3b65538f80601411f85295db8f4cb30ab.tar.gz
quagga: work with new readline
The Function and CPPFunction had been removed by in readline 6.3, use the new functions to replace them. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
-rw-r--r--meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch34
-rw-r--r--meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch b/meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch
new file mode 100644
index 0000000000..2bd333a70a
--- /dev/null
+++ b/meta-networking/recipes-protocols/quagga/files/work-with-new-readline.patch
@@ -0,0 +1,34 @@
+From 66df315d2a270a254c613a4d2e72c0ea47f15a71 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Thu, 27 Mar 2014 09:35:29 +0000
+Subject: [PATCH] vtysh/vtysh.c: works with new readline
+
+The Function and CPPFunction had been removed by in readline 6.3, use
+the new functions to replace them.
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ vtysh/vtysh.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/vtysh/vtysh.c b/vtysh/vtysh.c
+index 431c08e..fdd82fb 100644
+--- a/vtysh/vtysh.c
++++ b/vtysh/vtysh.c
+@@ -2212,9 +2212,9 @@ void
+ vtysh_readline_init (void)
+ {
+ /* readline related settings. */
+- rl_bind_key ('?', (Function *) vtysh_rl_describe);
++ rl_bind_key ('?', (rl_command_func_t *) vtysh_rl_describe);
+ rl_completion_entry_function = vtysh_completion_entry_function;
+- rl_attempted_completion_function = (CPPFunction *)new_completion;
++ rl_attempted_completion_function = (rl_completion_func_t *)new_completion;
+ /* do not append space after completion. It will be appended
+ * in new_completion() function explicitly. */
+ rl_completion_append_character = '\0';
+--
+1.8.3.4
+
diff --git a/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb b/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb
index db2a67b4a9..0988b70eb0 100644
--- a/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb
+++ b/meta-networking/recipes-protocols/quagga/quagga_0.99.21.bb
@@ -6,6 +6,7 @@ SRC_URI += "file://0001-doc-fix-makeinfo-errors-and-one-warning.patch \
file://lingering-IP-address-after-deletion-BZ-486.patch \
file://build-fix-extract.pl-for-cross-compilation.patch \
file://babel-close-the-stdout-stderr-as-in-other-daemons.patch \
+ file://work-with-new-readline.patch \
"
SRC_URI[quagga-0.99.21.md5sum] = "99840adbe57047c90dfba6b6ed9aec7f"