aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-06-17 22:34:44 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-06-18 22:11:14 +0100
commiteb426661f4c8d00703627cb35540cdc7dd1ec58b (patch)
treeab3155840922c0fc23c1d6faa5b1fe3eb91637ab
parentbb84e59036b350e29fe96e9aaa0614147d268fb9 (diff)
downloadmeta-openembedded-contrib-eb426661f4c8d00703627cb35540cdc7dd1ec58b.tar.gz
initramfs-kexecboot(-klibc)-image: provide SUMMARY and DESCRIPTION
* plus some minor editing of comments Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb10
-rw-r--r--meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb6
2 files changed, 9 insertions, 7 deletions
diff --git a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
index dbe558397e..dd6d07dfaf 100644
--- a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
+++ b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
@@ -1,6 +1,5 @@
-# Initramfs image providing kexecboot
-# a linux as bootloader implementation
-
+SUMMARY = "Initramfs image for kexecboot kernel"
+DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
@@ -9,9 +8,8 @@ IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
# avoid circular dependencies
EXTRA_IMAGEDEPENDS = ""
-# for ubiattach we have to install mtd-utils-ubifs
-# or use ubiattach-klibc instead
-IMAGE_INSTALL = "kexec kexecboot mtd-utils-ubifs"
+# We really need just kexecboot, kexec and ubiattach
+IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = ""
diff --git a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb
index 37349e1e20..df97511892 100644
--- a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb
+++ b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb
@@ -1,3 +1,7 @@
require initramfs-kexecboot-image.bb
-IMAGE_INSTALL = "kexec-klibc kexecboot-klibc ubiattach-klibc"
+SUMMARY = "Initramfs image for kexecboot kernel (klibc-static binaries)"
+
+# We really need just kexecboot, kexec and ubiattach
+# statically compiled against klibc
+IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc"