aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2021-06-09 09:31:33 -0500
committerKhem Raj <raj.khem@gmail.com>2021-06-09 12:18:10 -0700
commit020a1e95fa9f955cafef00b1f803c868197a645c (patch)
tree25c5f390bc355d3cf0d27a47128f7e1ee86d50d8
parent22491c404c9842a15df64bcd76003355940f62eb (diff)
downloadmeta-openembedded-contrib-020a1e95fa9f955cafef00b1f803c868197a645c.tar.gz
gnome: gnome-shell: Move gsettings to their own package
Moves the gnome-shell-gsettings package to it's own package so that other desktop environments that depends on it can pull it in without pulling in all of gnome-shell Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb
index 9619628c81..77b9015d46 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb
@@ -49,6 +49,8 @@ do_install_append() {
done
}
+GSETTINGS_PACKAGE = "${PN}-gsettings"
+
FILES_${PN} += " \
${datadir}/dbus-1 \
${datadir}/gnome-control-center \
@@ -56,9 +58,9 @@ FILES_${PN} += " \
${systemd_user_unitdir} \
"
-RDEPENDS_${PN} += "gsettings-desktop-schemas gdm-base librsvg-gtk"
+RDEPENDS_${PN} += "gsettings-desktop-schemas gdm-base librsvg-gtk ${PN}-gsettings"
-PACKAGES =+ "${PN}-tools"
+PACKAGES =+ "${PN}-tools ${PN}-gsettings"
FILES_${PN}-tools = "${bindir}/*-tool"
RDEPENDS_${PN}-tools = "python3-core"