aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Opdenacker <michael.opdenacker@bootlin.com>2021-09-01 13:57:17 +0200
committerKhem Raj <raj.khem@gmail.com>2021-09-01 08:25:42 -0700
commit103ca6420377f3e10aed7f463910ef6918f6726c (patch)
tree0cc4657d15ec2f057018325c30e8a665d22bf064
parent188b85e73f44220a95a811618f65d758912ab8bd (diff)
downloadmeta-openembedded-contrib-103ca6420377f3e10aed7f463910ef6918f6726c.tar.gz
meta-oe: stop using "virtual/" in RPROVIDES and RDEPENDS
Recipes shouldn't use the "virtual/" string in RPROVIDES and RDEPENDS. That's confusing because "virtual/" has no special meaning in RPROVIDES and RDEPENDS (unlike in PROVIDES and DEPENDS). Instead, using "virtual-" instead of "virtual/" as already done in the glibc recipe in OE-core Signed-off-by: Michael Opdenacker <michael.opdenacker@bootlin.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/dynamic-layers/gnome-layer/recipes-graphics/openbox/openbox-xdgmenu_0.3.bb2
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xterm_367.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/dynamic-layers/gnome-layer/recipes-graphics/openbox/openbox-xdgmenu_0.3.bb b/meta-oe/dynamic-layers/gnome-layer/recipes-graphics/openbox/openbox-xdgmenu_0.3.bb
index 93ef228efe..c85293aa5c 100644
--- a/meta-oe/dynamic-layers/gnome-layer/recipes-graphics/openbox/openbox-xdgmenu_0.3.bb
+++ b/meta-oe/dynamic-layers/gnome-layer/recipes-graphics/openbox/openbox-xdgmenu_0.3.bb
@@ -33,4 +33,4 @@ do_install() {
install -m 0755 openbox-xdgmenu ${D}${bindir}
}
-RDEPENDS:${PN} += "virtual/x-terminal-emulator"
+RDEPENDS:${PN} += "virtual-x-terminal-emulator"
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm_367.bb b/meta-oe/recipes-graphics/xorg-app/xterm_367.bb
index 81bfcf1142..ee25dc872c 100644
--- a/meta-oe/recipes-graphics/xorg-app/xterm_367.bb
+++ b/meta-oe/recipes-graphics/xorg-app/xterm_367.bb
@@ -37,7 +37,7 @@ do_install:append() {
oe_runmake install-desktop DESTDIR="${D}" DESKTOP_FLAGS="--dir=${D}${DESKTOPDIR}"
}
-RPROVIDES:${PN} = "virtual/x-terminal-emulator"
+RPROVIDES:${PN} = "virtual-x-terminal-emulator"
# busybox can supply resize too
inherit update-alternatives