aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-26 18:40:17 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-27 15:07:46 -0700
commit2f257049cf9a011e14518085168439ff611cd120 (patch)
treea2acbd267a769bcb4de75c04829946d710d353f0
parent3e7a259ec2e6b0fbf2371ac4ac110a0999bdf44b (diff)
downloadmeta-openembedded-contrib-2f257049cf9a011e14518085168439ff611cd120.tar.gz
python3-flask-wtf: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-flask-wtf.inc15
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb17
2 files changed, 16 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf.inc b/meta-python/recipes-devtools/python/python-flask-wtf.inc
deleted file mode 100644
index 8636711536..0000000000
--- a/meta-python/recipes-devtools/python/python-flask-wtf.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "Simple integration of Flask and WTForms."
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3ca6bb31670492f791e6a9f2fb9f8a80"
-
-SRC_URI[md5sum] = "586f50f233926cade42e3d744aca3e8f"
-SRC_URI[sha256sum] = "5d14d55cfd35f613d99ee7cba0fc3fbbe63ba02f544d349158c14ca15561cc36"
-
-PYPI_PACKAGE = "Flask-WTF"
-
-RDEPENDS_${PN} = "\
- ${PYTHON_PN}-flask \
- ${PYTHON_PN}-itsdangerous \
- ${PYTHON_PN}-json \
- ${PYTHON_PN}-wtforms \
-"
diff --git a/meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb b/meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb
index 52362a8659..33387045ea 100644
--- a/meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-wtf_0.14.2.bb
@@ -1,2 +1,17 @@
+DESCRIPTION = "Simple integration of Flask and WTForms."
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3ca6bb31670492f791e6a9f2fb9f8a80"
+
+SRC_URI[md5sum] = "586f50f233926cade42e3d744aca3e8f"
+SRC_URI[sha256sum] = "5d14d55cfd35f613d99ee7cba0fc3fbbe63ba02f544d349158c14ca15561cc36"
+
+PYPI_PACKAGE = "Flask-WTF"
+
inherit pypi setuptools3
-require python-flask-wtf.inc
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-flask \
+ ${PYTHON_PN}-itsdangerous \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-wtforms \
+"