aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-29 18:28:56 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-29 19:18:27 -0700
commit5ce7a2a89b9447e14f6cb60a0af9128987478a78 (patch)
tree3bbfefff83ff00c8a7d1004e03dd54e19ffaabc2
parent3e1007146c8d01839112043d625a8495b4947b87 (diff)
downloadmeta-openembedded-contrib-5ce7a2a89b9447e14f6cb60a0af9128987478a78.tar.gz
xterm: Add _GNU_SOURCE via CFLAGS
This ensures that definitions of functions e.g. ptsname and wcwidth are added correctly. Fixes | ./main.c:2940:8: error: incompatible integer to pointer conversion initializing 'char *' with an expression of type 'int' [-Wint-conversion] | char *name = ptsname(*pty); | ^ ~~~~~~~~~~~~~ | ./util.c:5506:19: error: use of undeclared identifier 'wcwidth' | my_wcwidth = wcwidth; | ^ Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xterm_373.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm_373.bb b/meta-oe/recipes-graphics/xorg-app/xterm_373.bb
index 7e36f475c4..bc555cbcd9 100644
--- a/meta-oe/recipes-graphics/xorg-app/xterm_373.bb
+++ b/meta-oe/recipes-graphics/xorg-app/xterm_373.bb
@@ -27,6 +27,8 @@ EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
B = "${S}"
+CFLAGS += "-D_GNU_SOURCE"
+
do_configure() {
gnu-configize --force
sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure