aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2021-09-14 22:02:32 -0700
committerKhem Raj <raj.khem@gmail.com>2021-09-15 06:53:22 -0700
commit5eb46e36a66836f6bbc8a0ffd54ae8a7c10a841f (patch)
tree9e9a79c2ce1775a4022bf70c569a6ed3c4d52e69
parente4a3c66505069ab076e377b43ee2b721ef4f11c7 (diff)
downloadmeta-openembedded-contrib-5eb46e36a66836f6bbc8a0ffd54ae8a7c10a841f.tar.gz
Boost-url Move to latest version
This commit aims to update the version of boost-url to latest, and to make compatibility changes to make the latest version build. As of 0b96da0e4727c692c48cc95a32d82634cb41aaaf on the boost url repo, the standalone build type has been removed, which breaks this recipe. A quick discussion with the maintainers [1] shows that the cmake was never really intended to be used for installation, even if it worked in the past, and in the future only intended for use within the boost superproject. They recommended that since this is a header only library, that a simple copy would be a better way to stay up to date with this library. As such, this commit removes the cmake bbclass, and replaces it with a simple do_install that is a simply copy into the include directories. At the same time, the previous patch to add GNUInstallDirs support to the cmake no longer applies, and is no longer needed, so it is removed at the same time. The SHA1 is also updated to the latest available. [1] https://cpplang.slack.com/archives/C01JR6C9C4U/p1631654296241200 Signed-off-by: Ed Tanous <ed@tanous.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch57
-rw-r--r--meta-oe/recipes-devtools/boost-url/boost-url_git.bb13
2 files changed, 7 insertions, 63 deletions
diff --git a/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch b/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
deleted file mode 100644
index 4c996656c0..0000000000
--- a/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 329e27c8ad30e76ab50c7949cc95ba8eb0efabd2 Mon Sep 17 00:00:00 2001
-From: Anton Blanchard <anton@ozlabs.org>
-Date: Tue, 17 Aug 2021 09:53:41 +1000
-Subject: [PATCH] Use GNUInstallDirs instead of hard wiring install directories
-
-On a multilib setup cmake files should go into lib64.
-
-Upstream-Status: Submitted [https://github.com/CPPAlliance/url/pull/38]
----
- CMakeLists.txt | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5b53f31..ebb7346 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -109,20 +109,22 @@ else()
- endif()
-
- if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR AND NOT BOOST_URL_IN_BOOST_TREE)
-+ include(GNUInstallDirs)
-+
- set_target_properties(boost_url PROPERTIES EXPORT_NAME url)
- install(TARGETS boost_url EXPORT boost_url_targets)
-
- install(EXPORT boost_url_targets
- FILE boost_url-targets.cmake
- NAMESPACE Boost::
-- DESTINATION lib/cmake/boost_url
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url
- )
-
- include(CMakePackageConfigHelpers)
-
- configure_package_config_file(cmake/config.cmake.in
- ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config.cmake
-- INSTALL_DESTINATION lib/cmake/boost_url
-+ INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url
- )
-
- write_basic_package_version_file(${CMAKE_CURRENT_BINARY_DIR}/boost_url-config-version.cmake
-@@ -132,10 +134,10 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR AND NOT BOOST_URL_IN_BOOST
- install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config.cmake
- ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config-version.cmake
-- DESTINATION lib/cmake/boost_url
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url
- )
-
-- install(DIRECTORY include/ DESTINATION include)
-+ install(DIRECTORY include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
- endif()
-
- if(BOOST_URL_BUILD_TESTS)
---
-2.31.1
-
diff --git a/meta-oe/recipes-devtools/boost-url/boost-url_git.bb b/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
index cb3664fe30..9f759100b8 100644
--- a/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
+++ b/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
@@ -4,16 +4,17 @@ SECTION = "libs"
LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
-SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop \
- file://0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch \
- "
+SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop"
-SRCREV = "2c867fbe284ae532f1329b87a86ad3f8cd382867"
+SRCREV = "4f712ed69a04a344957d22efa5dc111b415b3aff"
S = "${WORKDIR}/git"
-inherit cmake
-
DEPENDS = "boost"
BBCLASSEXTEND = "native nativesdk"
+
+do_install() {
+ mkdir -p ${D}/${includedir}
+ cp -r ${S}/include/** ${D}/${includedir}/
+}