aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-29 18:16:03 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-29 21:09:39 -0800
commit7c82652b2a0f254d83a4629251af5272fd05f4b2 (patch)
tree5a45a9153710592652c61c435b9f6342d4a24213
parenteffbeeff2ee8d9ef17f454f00b03a618f94b8520 (diff)
downloadmeta-openembedded-contrib-7c82652b2a0f254d83a4629251af5272fd05f4b2.tar.gz
mongodb: Upgrade to 4.4.18
Use wildchar instead of /opt/ for build paths becasue it might be different when building with ccache Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
index b4567d098a..524f0fc90c 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
@@ -11,9 +11,9 @@ DEPENDS = "openssl libpcap zlib boost curl python3 \
inherit scons dos2unix siteinfo python3native systemd useradd
-PV = "4.4.13"
-#v4.4.13
-SRCREV = "df25c71b8674a78e17468f48bcda5285decb9246"
+PV = "4.4.18"
+#v4.4.18
+SRCREV = "8ed32b5c2c68ebe7f8ae2ebe8d23f36037a17dea"
SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4;protocol=https \
file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \
file://0001-Use-long-long-instead-of-int64_t.patch \
@@ -103,8 +103,8 @@ scons_do_install() {
# install binaries
install -d ${D}${bindir}
for i in mongod mongos mongo; do
- if [ -f ${B}/build/opt/mongo/$i ]; then
- install -m 0755 ${B}/build/opt/mongo/$i ${D}${bindir}
+ if [ -f ${B}/build/*/mongo/$i ]; then
+ install -m 0755 ${B}/build/*/mongo/$i ${D}${bindir}
else
bbnote "$i does not exist"
fi