aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-30 13:49:54 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-31 08:30:19 -0700
commit874a6c7a994c5ed8753fa51d746ccc5dc10d176c (patch)
treeb75798f5c4e2847d2c247dea25235ef692aa6114
parent48cd26a743f46785701e19e322edf5692a4e1a45 (diff)
downloadmeta-openembedded-contrib-874a6c7a994c5ed8753fa51d746ccc5dc10d176c.tar.gz
mime-support: Use update-alternatives
mime.types is also provided by mailcap so use update-alternatives to install is policy when both are added into image Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/mailcap/mailcap_2.1.49.bb5
-rw-r--r--meta-oe/recipes-support/mime-support/mime-support_3.48.bb6
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mailcap/mailcap_2.1.49.bb b/meta-oe/recipes-support/mailcap/mailcap_2.1.49.bb
index ff3047f325..537c458747 100644
--- a/meta-oe/recipes-support/mailcap/mailcap_2.1.49.bb
+++ b/meta-oe/recipes-support/mailcap/mailcap_2.1.49.bb
@@ -21,6 +21,11 @@ SRC_URI = "https://releases.pagure.org/${BPN}/${BP}.tar.xz"
SRC_URI[md5sum] = "d5701a1a541383c0eda328f4a6518751"
SRC_URI[sha256sum] = "f7381516bc1a937348efd1d0e14618e0a2afc5d59fe821dd248632d5601b59b5"
+inherit update-alternatives
+
do_install() {
oe_runmake install DESTDIR=${D} sysconfdir=${sysconfdir} mandir=${mandir}
}
+
+ALTERNATIVE_${PN} = "mime.types"
+ALTERNATIVE_LINK_NAME[mime.types] = "${sysconfdir}/mime.types"
diff --git a/meta-oe/recipes-support/mime-support/mime-support_3.48.bb b/meta-oe/recipes-support/mime-support/mime-support_3.48.bb
index d617b6620c..1137f5012a 100644
--- a/meta-oe/recipes-support/mime-support/mime-support_3.48.bb
+++ b/meta-oe/recipes-support/mime-support/mime-support_3.48.bb
@@ -10,6 +10,8 @@ RRECOMMENDS_${PN} = "file"
SRC_URI = "${DEBIAN_MIRROR}/main/m/mime-support/mime-support_${PV}-1.tar.gz"
S = "${WORKDIR}/${BPN}"
+inherit update-alternatives
+
FILES_${PN} += " ${libdir}/mime"
docdir_append = "/${BPN}"
@@ -56,3 +58,7 @@ do_install () {
SRC_URI[md5sum] = "d6e5d715e331147352c50c158dbdec6d"
SRC_URI[sha256sum] = "a529c7892cb786f514af71f4ca5a4c3ebc58b538a49ff959c0d97592d38f040a"
+
+ALTERNATIVE_PRIORITY = "90"
+ALTERNATIVE_${PN} = "mime.types"
+ALTERNATIVE_LINK_NAME[mime.types] = "${sysconfdir}/mime.types"